summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2022-09-29 23:33:25 +0000
committerPellegrino Prevete2022-09-29 23:33:25 +0000
commitcd048c3f0be812d7671e8c0b6e04dff162706a61 (patch)
treecc04c47953bb2abe31e2c78c51c98146c98d9b18
parentd3e01ec7a46005eb61126ec2f0dbe91772ee1ad8 (diff)
downloadaur-cd048c3f0be812d7671e8c0b6e04dff162706a61.tar.gz
upgrade PKGBUILD
-rw-r--r--PKGBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cc7cd4e22ba..47a3952cd36d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,30 @@
# Maintainer: Ernesto Castellotti <erny.castell@gmail.com>
+# Contributor: Pellegrino Prevete <pellegrinoprevete@gmail.com>
-_pkgname=blivet
-pkgname=python-$_pkgname-git
+# shellcheck disable=SC2034
+_pkg="blivet"
+_pkgname="python-${_pkg}"
+pkgname="${_pkgname}-git"
pkgver=bf9b55b
pkgrel=2
pkgdesc='a python module for management of a system storage configuration - python 3.x pkg'
-arch=('i686' 'x86_64' 'pentium4')
-depends=('multipath-tools' 'mpathconf' 'mdadm' 'libblockdev' 'libselinux' 'python-six' 'python-pyudev' 'hawkey' 'python-pyparted' 'python-pykickstart')
+arch=('x86_64' 'i686' 'pentium4')
+depends=('multipath-tools' 'mpathconf' 'mdadm' 'libblockdev' 'libselinux'
+ 'python-six' 'python-pyudev' 'hawkey' 'python-pyparted' 'python-pykickstart')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
license=('LGPL2.1')
url='http://fedoraproject.org/wiki/Blivet'
-source=("git+https://github.com/storaged-project/blivet.git")
+source=("git+https://github.com/storaged-project/${_pkg}.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "${_pkgbase}"
+ git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
+}
+
+# shellcheck disable=SC2154
package() {
- cd "${srcdir}/$_pkgname"
+ cd "${srcdir}/$_pkg" || exit
python setup.py install --root="${pkgdir}/" --optimize=1
}
-
-