summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2020-01-17 09:31:23 -0700
committeryochananmarqos2020-01-17 09:31:23 -0700
commit1648d612f9f368d51cc30d6d5018965d02397943 (patch)
treeef6a4bc939931d0c5593a1c446d6b998f7619b3b
parentb8aee9316dab974ea37177a4be01221452261882 (diff)
downloadaur-1648d612f9f368d51cc30d6d5018965d02397943.tar.gz
add license
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 284ae2d7ff28..cb69c3396de9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = python-block_tracing
pkgdesc = Protect process memory
pkgver = 1.0.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/rianhunter/block_tracing
- arch = i686
- arch = x86_64
- license = GPL3
+ arch = any
+ license = MIT
makedepends = python-setuptools
depends = python
source = https://files.pythonhosted.org/packages/source/b/block_tracing/block_tracing-1.0.1.tar.gz
+ source = https://raw.githubusercontent.com/rianhunter/block_tracing/master/LICENSE
sha256sums = 9faa009a702a8f2f605ebb78314d5ca2a2a93543d061038a3d3a978c93385e68
+ sha256sums = b6fe6404f46a6a82220d921d7854fa8c20c8ea40ff0d0e24748b46878c5d291f
pkgname = python-block_tracing
diff --git a/PKGBUILD b/PKGBUILD
index 937fd371a567..05936b8a5824 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
pkgname=python-block_tracing
_name=block_tracing
pkgver=1.0.1
-pkgrel=3
+pkgrel=4
pkgdesc="Protect process memory"
-arch=('i686' 'x86_64')
+arch=('any')
url="https://github.com/rianhunter/block_tracing"
-license=('GPL3')
+license=('MIT')
depends=('python')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('9faa009a702a8f2f605ebb78314d5ca2a2a93543d061038a3d3a978c93385e68')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/rianhunter/$_name/master/LICENSE")
+sha256sums=('9faa009a702a8f2f605ebb78314d5ca2a2a93543d061038a3d3a978c93385e68'
+ 'b6fe6404f46a6a82220d921d7854fa8c20c8ea40ff0d0e24748b46878c5d291f')
build() {
cd "$_name-$pkgver"
@@ -20,4 +22,6 @@ build() {
package() {
cd "$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+
+ install -Dm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
}