summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-08-18 13:09:05 -0600
committerMark Wagie2021-08-18 13:09:05 -0600
commitb8e82c874ca267d2d91cf4381093af59dae08cb7 (patch)
tree51996089ae84170cd2d106efdcc848b067d47057
parent8945eb5c6b5e0efb3fbbca804d1d0f3f67589951 (diff)
downloadaur-b8e82c874ca267d2d91cf4381093af59dae08cb7.tar.gz
PKGBUILD adjustments
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD18
4 files changed, 35 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 912746e75417..aa6fa6a36afb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,18 +2,17 @@ pkgbase = python-block_tracing
pkgdesc = Protect process memory
pkgver = 1.0.1
pkgrel = 6
- url = https://github.com/rianhunter/block_tracing
+ url = https://thelig.ht/code/block-tracing
arch = any
license = MIT
makedepends = python-setuptools
depends = python
- source = https://files.pythonhosted.org/packages/source/b/block_tracing/block_tracing-1.0.1.tar.gz
- source = https://files.pythonhosted.org/packages/source/b/block_tracing/block_tracing-1.0.1.tar.gz.asc
- source = https://raw.githubusercontent.com/rianhunter/block_tracing/master/LICENSE
+ source = https://pypi.org/packages/source/b/block_tracing/block_tracing-1.0.1.tar.gz
+ source = https://pypi.org/packages/source/b/block_tracing/block_tracing-1.0.1.tar.gz.asc
+ source = LICENSE
validpgpkeys = 584EDA5AAC13B9FBFB13F678A6A5398DACC9C15C
sha256sums = 9faa009a702a8f2f605ebb78314d5ca2a2a93543d061038a3d3a978c93385e68
sha256sums = SKIP
sha256sums = b6fe6404f46a6a82220d921d7854fa8c20c8ea40ff0d0e24748b46878c5d291f
pkgname = python-block_tracing
-
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..c6a96c1ad7ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!LICENSE
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..2af15df944f6
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2018 Rian Hunter
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 0e760268ef30..5871a42c9dd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,26 @@ pkgver=1.0.1
pkgrel=6
pkgdesc="Protect process memory"
arch=('any')
-url="https://github.com/rianhunter/block_tracing"
+url="https://thelig.ht/code/block-tracing"
license=('MIT')
depends=('python')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"{,.asc}
- "https://raw.githubusercontent.com/rianhunter/$_name/master/LICENSE")
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"{,.asc}
+ 'LICENSE')
sha256sums=('9faa009a702a8f2f605ebb78314d5ca2a2a93543d061038a3d3a978c93385e68'
'SKIP'
'b6fe6404f46a6a82220d921d7854fa8c20c8ea40ff0d0e24748b46878c5d291f')
validpgpkeys=('584EDA5AAC13B9FBFB13F678A6A5398DACC9C15C') # Rian Hunter <rian@thelig.ht>
build() {
- cd "$_name-$pkgver"
- python setup.py build
+ cd "$_name-$pkgver"
+ python setup.py build
}
package() {
- cd "$_name-$pkgver"
- export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd "$_name-$pkgver"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
}