summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2020-04-03 13:06:28 -0400
committerGI_Jack2020-04-03 13:06:28 -0400
commit049c0549bf49ef732a94e92ae31fa0094967fd90 (patch)
tree5c16ee639bdefe97b205791337816e196f9131a0
downloadaur-049c0549bf49ef732a94e92ae31fa0094967fd90.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0724b5d3d82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-bls
+ pkgdesc = BLS12-381 and Signatures in Python
+ pkgver = 0.1.8
+ pkgrel = 1
+ url = https://github.com/zebra-lucky/python-bls
+ arch = any
+ license = Apache2
+ makedepends = python-setuptools
+ depends = python
+ source = python-bls-0.1.8.tar.gz::https://github.com/zebra-lucky/python-bls/archive/0.1.8.tar.gz
+ sha256sums = bb61c66f4fb543698a7abd93a2991e9d4430c35698f163fc43004a198465c834
+
+pkgname = python-bls
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb5f6e881bd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: GI_Jack <GI_Jack@hackermail.com>
+
+pkgname=python-bls
+pkgver=0.1.8
+pkgrel=1
+pkgdesc="BLS12-381 and Signatures in Python"
+url="https://github.com/zebra-lucky/python-bls"
+arch=('any')
+license=('Apache2')
+depends=('python')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/zebra-lucky/${pkgname}/archive/${pkgver}.tar.gz")
+
+sha256sums=('bb61c66f4fb543698a7abd93a2991e9d4430c35698f163fc43004a198465c834')
+
+package() {
+ cd ${pkgname}-${pkgver}
+ python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+}