summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNils Czernia2019-05-15 09:58:08 +0200
committerNils Czernia2019-05-15 09:58:08 +0200
commitbbb5fc0c9229becea1dcd48da98a78d629dc4ed5 (patch)
treeda8c26d94369e150339674d43749a53b8e9b3125
downloadaur-bbb5fc0c9229becea1dcd48da98a78d629dc4ed5.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40578ff647d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-bme280-git
+ pkgdesc = A Python library for accessing the BME280 combined humidity and pressure from Bosch via python-smbus using the I2C interface.
+ pkgver = cced71b
+ pkgrel = 1
+ url = https://github.com/cmur2/python-bme280
+ arch = any
+ license = MIT
+ depends = python
+ source = bme280::git+https://github.com/cmur2/python-bme280.git
+ sha512sums = SKIP
+
+pkgname = python-bme280-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..012041038706
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Nils Czernia <nils[at]czserver.de>
+
+pkgname=python-bme280-git
+_pkgname=bme280
+pkgver=cced71b
+pkgrel=1
+pkgdesc="A Python library for accessing the BME280 combined humidity and pressure from Bosch via python-smbus using the I2C interface."
+url="https://github.com/cmur2/python-bme280"
+arch=("any")
+license=("MIT")
+depends=("python")
+source=("${_pkgname}::git+https://github.com/cmur2/python-bme280.git")
+sha512sums=("SKIP")
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --always | sed -e 's|-|.|g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --skip-build -O1 --root="${pkgdir}"
+}
+
+# vim: ts=2 sw=2 et: