summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2021-01-28 11:15:19 +0800
committeryjun2021-01-28 11:15:19 +0800
commit2e90bf6eddbadbd46f7f96b659b84eb7d8e0a37c (patch)
treebbbc08f363574e2f649051051b9618942b15eb42
downloadaur-2e90bf6eddbadbd46f7f96b659b84eb7d8e0a37c.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23b6c74513d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-bmp2hex-git
+ pkgdesc = Python utility to convert 1-, 4-, 8- and 16-bit bitmap files to hex. Used to embed graphics in Arduino/C code, primarily for display.
+ pkgver = 2.3.4.ac6c665
+ pkgrel = 1
+ url = https://github.com/robertgallup/python-bmp2hex
+ arch = any
+ license = MIT
+ depends = python
+ provides = python-bmp2hex
+ conflicts = python-bmp2hex
+ source = git+https://github.com/robertgallup/python-bmp2hex
+ sha256sums = SKIP
+
+pkgname = python-bmp2hex-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d71dcdc26784
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: yjun <jerrysteve1101@gmail.com>
+
+pkgname=python-bmp2hex-git
+_pkgname=${pkgname%-git}
+_script=${_pkgname#python-}
+pkgver=2.3.4.ac6c665
+pkgrel=1
+pkgdesc="Python utility to convert 1-, 4-, 8- and 16-bit bitmap files to hex. Used to embed graphics in Arduino/C code, primarily for display."
+arch=('any')
+url="https://github.com/robertgallup/python-bmp2hex"
+license=('MIT')
+depends=('python')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+https://github.com/robertgallup/python-bmp2hex")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+
+ printf "%s.%s" "$(python -c "import ${_script};print(${_script}.DEFAULTS().VERSION)")" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 ${_pkgname}/${_script}.py ${pkgdir}/usr/bin/${_script}
+ install -Dm644 ${_pkgname}/license.txt -t ${pkgdir}/usr/share/licenses/${pkgname}/
+}
+# vim: set sw=2 ts=2 et: