summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Turner2017-01-04 20:18:02 -0500
committerWilliam Turner2017-01-04 20:18:02 -0500
commit99b6d6414b905f9c509ed98f448aa6305f16d6d9 (patch)
treebf36d08f2702951d7c6d56b6d7ec3c84e81f4609
downloadaur-99b6d6414b905f9c509ed98f448aa6305f16d6d9.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD50
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a736db2efb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-booleanoperations
+ pkgdesc = Boolean operations on paths based on a super fast polygon clipper library by Angus Johnson.
+ pkgver = 0.6.4
+ pkgrel = 1
+ url = https://github.com/typemytype/booleanOperations
+ arch = any
+ license = MIT
+ makedepends = python-pip
+ makedepends = python2-pip
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/py2.py3/b/booleanOperations/booleanOperations-0.6.4-py2.py3-none-any.whl
+ sha256sums = da2654471d8f748b7743a4a10f5e07706a470f1f4dff1ffd76b4c859bcfc6ac5
+
+pkgname = python-booleanoperations
+ depends = python
+ provides = python-booleanoperations
+
+pkgname = python2-booleanoperations
+ depends = python2
+ provides = python2-booleanoperations
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5aba3c7d094c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: William Turner <willtur.will@gmail.com>
+pkgbase=python-booleanoperations
+pkgname=(python-booleanoperations python2-booleanoperations)
+_pkgname=booleanOperations
+pkgver=0.6.4
+pkgrel=1
+pkgdesc='Boolean operations on paths based on a super fast polygon clipper library by Angus Johnson.'
+arch=('any')
+url='https://github.com/typemytype/booleanOperations'
+license=('MIT')
+makedepends=('python-pip' 'python2-pip')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/py2.py3/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}-py2.py3-none-any.whl")
+sha256sums=('da2654471d8f748b7743a4a10f5e07706a470f1f4dff1ffd76b4c859bcfc6ac5')
+
+package_python-booleanoperations() {
+ depends=('python')
+ provides=('python-booleanoperations')
+
+ cd "${srcdir}"
+
+ # install the wheel
+ PIP_CONFIG_FILE=/dev/null pip install \
+ --isolated \
+ --root="${pkgdir}" \
+ --ignore-installed \
+ --no-deps \
+ ${_pkgname}-${pkgver}-py2.py3-none-any.whl
+
+ # compile to pyo
+ python -O -m compileall "${pkgdir}"
+}
+
+package_python2-booleanoperations() {
+ depends=('python2')
+ provides=('python2-booleanoperations')
+
+ cd "${srcdir}"
+
+ # install the wheel
+ PIP_CONFIG_FILE=/dev/null pip2 install \
+ --isolated \
+ --root="${pkgdir}" \
+ --ignore-installed \
+ --no-deps \
+ ${_pkgname}-${pkgver}-py2.py3-none-any.whl
+
+ # compile to pyo
+ python2 -O -m compileall "${pkgdir}"
+}