summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2020-12-11 22:07:54 -0500
committerChris Severance2020-12-11 22:07:54 -0500
commitf1995942aa7b451231a2938f3546555fcc953291 (patch)
tree6809377b598b56c71e26cee705ef8216ea49866b
parent04bf2545cb14e7de901d9975b179ed6476325b0a (diff)
downloadaur-python-botocore-git.tar.gz
Update to 1.19.35
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 533b26d86a34..0b5fb8468cbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Aug 18 05:07:32 UTC 2020
+# Sat Dec 12 03:07:53 UTC 2020
pkgbase = python-botocore-git
pkgdesc = A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3
- pkgver = 1.17.44.r7044.g5986ae80c
+ pkgver = 1.19.35
pkgrel = 1
url = https://github.com/boto/botocore
arch = any
@@ -13,8 +13,7 @@ pkgbase = python-botocore-git
depends = python
depends = python-dateutil>=2.1
depends = python-jmespath>=0.7.1
- depends = python-docutils>=0.10
- depends = python-urllib3>=1.20
+ depends = python-urllib3>=1.25.4
depends = python-tox>=2.5.0
depends = python-nose>=1.3.7
depends = python-mock>=1.3.0
@@ -25,10 +24,11 @@ pkgbase = python-botocore-git
depends = python-sphinx>=1.1.3
depends = python-guzzle-sphinx-theme>=0.7.10
depends = python-six>=1.1.0
- provides = python-botocore=1.17.44
+ provides = python-botocore=1.19.35
conflicts = python-botocore
options = !strip
source = botocore::git+https://github.com/boto/botocore.git
+ md5sums = 511f6efe69d9589cf32034f9ea3040ea
sha256sums = SKIP
pkgname = python-botocore-git
diff --git a/PKGBUILD b/PKGBUILD
index 97f427f21738..c445b1e4fa0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,23 +21,21 @@ tox>=2.5.0,<3.0.0
nose==1.3.7
mock==1.3.0
wheel==0.24.0
-docutils>=0.10,<0.16
behave==1.2.5
jsonschema==2.5.1
#setup.py
requires = [
'jmespath>=0.7.1,<1.0.0',
- 'docutils>=0.10,<0.16',
'python-dateutil>=2.1,<3.0.0',
]
if sys.version_info[:2] == (3, 4):
# urllib3 dropped support for python 3.4 in point release 1.25.8
- requires.append('urllib3>=1.20,<1.25.8')
+ requires.append('urllib3>=1.25.4,<1.25.8')
else:
- requires.append('urllib3>=1.20,<1.26')
+ requires.append('urllib3>=1.25.4,<1.27')
"
}
unset -f _fn_foobar
@@ -46,7 +44,7 @@ set -u
_pyver="python"
_pybase='botocore'
pkgname="${_pyver}-${_pybase}-git"
-pkgver=1.17.44.r7044.g5986ae80c
+pkgver=1.19.35
pkgrel=1
pkgdesc='A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3'
arch=('any')
@@ -56,8 +54,8 @@ _pydepends=( # See setup.py, README.rst, and requirements.txt for version depend
# setup.py
"${_pyver}-dateutil"'>=2.1' #,'<3.0.0'}
"${_pyver}-jmespath"'>=0.7.1' #,'<1.0.0'}
- "${_pyver}-docutils>=0.10" #,'0.16'}
- "${_pyver}-urllib3"'>=1.20' #,'<1.26'}
+ #"${_pyver}-docutils>=0.10" #,'0.16'}
+ "${_pyver}-urllib3"'>=1.25.4' #,'<1.27'}
# requirements.txt
"${_pyver}-tox"'>=2.5.0' #,'<3.0.0'}
@@ -80,7 +78,8 @@ depends=("${_pyver}" "${_pydepends[@]}")
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
options=('!strip')
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('07e902e82963b98af99606fc58f2d04dfec5b2768209477ac1642c4ee1550574')
+md5sums=('511f6efe69d9589cf32034f9ea3040ea')
+sha256sums=('94097e76158c6f7db0c6575cd8e4aae021a5bed8bd6a5a29f0cb8d46a98b30e9')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
_srcdir="${_pybase}"