summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-08-13 20:23:23 -0400
committerChris Severance2015-08-13 20:23:23 -0400
commit38096ed0c2a5769fca18f48d0a87da35d4b00d75 (patch)
tree1fd1aa498684181d98d01cd90b679856f57679e6
parent8ad181c6ef572983168a71a858d6bef0454d8d58 (diff)
downloadaur-38096ed0c2a5769fca18f48d0a87da35d4b00d75.tar.gz
Documented dependencies
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d39e049a3af..d4fb7bb2975e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,8 +14,10 @@ pkgbase = python-botocore-git
depends = python-tox>=1.4
depends = python-sphinx>=1.1.3
depends = python-dateutil>=2.1
+ depends = python-dateutil<3.0.0
depends = python-nose>=1.3.0
depends = python-mock>=1.0.1
+ depends = python-docutils>=0.10
depends = python-six>=1.1.0
provides = python-botocore=1.1.8
conflicts = python2-botocore
diff --git a/PKGBUILD b/PKGBUILD
index 370edca802c7..628549cd99ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,16 @@ arch=('any')
url="https://github.com/boto/${_pkgname}"
license=('Apache') # Apache License 2.0
depends=('python' # See setup.py, README.rst, and requirements.txt for version dependencies
- 'python-bcdoc<0.15.0'
- 'python-wheel>=0.24.0'
- 'python-jmespath>=0.7.1'
- 'python-tox>=1.4'
- 'python-sphinx>=1.1.3'
- 'python-dateutil>=2.1' # 'python-dateutil<3.0.0' this is an old requirement
- 'python-nose>=1.3.0'
- 'python-mock>=1.0.1'
- 'python-six>=1.1.0'
+ 'python-bcdoc<0.15.0' # AUR
+ 'python-wheel>=0.24.0' # AUR ==
+ 'python-jmespath>=0.7.1' # AUR == is possible for repositories. Makes upgrades impossible in AUR.
+ 'python-tox>=1.4' # COM == is possible because this is from a repository. Unfortunatley Arch isn't the primary dev environment for botocore/aws so our packages are likely to be newer.
+ 'python-sphinx>=1.1.3' #'python-sphinx<1.3' # COM Arch is already newer. Documentation might not work.
+ 'python-dateutil>=2.1' 'python-dateutil<3.0.0' # COM
+ 'python-nose>=1.3.0' # COM ==
+ 'python-mock>=1.0.1' # COM ==
+ 'python-docutils>=0.10' # COM
+ 'python-six>=1.1.0' # COM This is in the sources but I'm not sure where the version comes from.
)
makedepends=('python-distribute') # same as python-setuptools
conflicts=('python2-botocore')