summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2018-02-11 18:03:34 -0500
committerChris Severance2018-02-11 18:03:34 -0500
commit67aa4c7101fdbb6acb2574ab0e03936955799ca5 (patch)
treeadd714758483443920c2fbe30234781161286b55
parentdbd341130b24f49113bc27c4223f235756a3e475 (diff)
downloadaur-67aa4c7101fdbb6acb2574ab0e03936955799ca5.tar.gz
Update to 1.8.40
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e697be8deeda..b2c76dc71f92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Feb 3 03:54:18 UTC 2018
+# Sun Feb 11 23:03:34 UTC 2018
pkgbase = python-botocore-git
pkgdesc = A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3
- pkgver = 1.8.36.r4321.g67927b8d
+ pkgver = 1.8.40.r4347.gaa056991
pkgrel = 1
url = https://github.com/boto/botocore
arch = any
@@ -15,6 +15,7 @@ pkgbase = python-botocore-git
depends = python-wheel>=0.24.0
depends = python-jmespath>=0.7.1
depends = python-jmespath<1.0.0
+ depends = python-jsonschema>=2.5.1
depends = python-tox>=2.5.0
depends = python-tox<3.0.0
depends = python-dateutil>=2.1
@@ -27,7 +28,7 @@ pkgbase = python-botocore-git
depends = python-guzzle-sphinx-theme>=0.7.10
depends = python-guzzle-sphinx-theme<0.8
depends = python-behave>=1.2.5
- provides = python-botocore=1.8.36
+ provides = python-botocore=1.8.40
conflicts = python-botocore
options = !strip
source = botocore::git+https://github.com/boto/botocore.git
diff --git a/PKGBUILD b/PKGBUILD
index 68605bb76343..36a1d8f50b64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,6 +24,7 @@ wheel==0.24.0
docutils>=0.10
behave==1.2.5
-e git://github.com/boto/jmespath.git@develop#egg=jmespath
+jsonschema==2.5.1
#setup.py
from setuptools import setup, find_packages
@@ -43,7 +44,7 @@ set -u
_pyver="python"
_pybase='botocore'
pkgname="${_pyver}-${_pybase}-git"
-pkgver=1.8.36.r4321.g67927b8d
+pkgver=1.8.40.r4347.gaa056991
pkgrel=1
pkgdesc='A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3'
arch=('any')
@@ -53,6 +54,7 @@ _pydepends=( # See setup.py, README.rst, and requirements.txt for version depend
"${_pyver}-bcdoc<0.15.0" # AUR
"${_pyver}-wheel>=0.24.0" # AUR ==
"${_pyver}-jmespath"{'>=0.7.1','<1.0.0'} # AUR == is possible for repositories. Makes upgrades impossible in AUR.
+ "${_pyver}-jsonschema>=2.5.1" # COM
"${_pyver}-tox"{'>=2.5.0','<3.0.0'} # COM == is possible because this is from a repository. Unfortunatley Arch isn"t the primary dev environment for botocore/aws so our packages are likely to be newer.
"${_pyver}-dateutil"{">=2.1","<3.0.0"} # COM
"${_pyver}-nose>=1.3.0" # COM ==
@@ -68,7 +70,7 @@ depends=("${_pyver}" "${_pydepends[@]}")
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
options=('!strip')
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('711d1fd3d0c94cabca9a231544316c2a6f3c8905b3965a574bd3a373a0b5b7ff')
+sha256sums=('728c28cc8efb57881ad0b2afcf1ac642c7dccde39a40a34915ea7c9bd0d9fa2b')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
_srcdir="${_pybase}"