summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-08-18 22:02:01 -0400
committerChris Severance2015-08-18 22:02:01 -0400
commit6cf7e9de72803fe8ed5b2ba9d8a58ea6c1300a0c (patch)
treef480c50fecf927532a6133c3eb6ac199997e0789
parent38096ed0c2a5769fca18f48d0a87da35d4b00d75 (diff)
downloadaur-6cf7e9de72803fe8ed5b2ba9d8a58ea6c1300a0c.tar.gz
Fixed set -u; msg with --nocolor
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4fb7bb2975e..15800ae87835 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-botocore-git
pkgdesc = A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3
- pkgver = 1.1.8.r2084.gc47c708
+ pkgver = 1.1.8.r2097.g9325508
pkgrel = 1
url = https://github.com/boto/botocore
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 628549cd99ae..11ac0a3ed756 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,14 @@
# aws-cli & aws-cli-git
# python-botocore & python-botocore-git
+# TODO: Do we need split packages for python2 (see python-wheel for example)
+
# Note: the primary use of this package is with aws-cli
set -u
_pkgname='botocore'
pkgname="python-${_pkgname}-git"
-pkgver=1.1.8.r2084.gc47c708
+pkgver=1.1.8.r2097.g9325508
pkgrel=1
pkgdesc='A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3'
arch=('any')
@@ -51,10 +53,6 @@ else
_verurl="${url}/releases"
_versed="${url#*github.com}/archive/\(.*\)\.tar\.gz" # used with ^...$
_veropt='l'
-# Return sorted list of all version numbers available (used by git-aurcheck)
-_version() {
- curl -s -l "${_verurl}" | _getlinks "${_veropt}" | sed -ne "s:^${_versed}"'$:\1:p' | tr '.' ':' | LC_ALL=C sort -n | tr ':' '.' # 1>&2
-}
fi
build() {
@@ -72,7 +70,7 @@ check() {
}
package() {
- set -u
+ # set -u # not compatible with msg and makepkg --nocolor
cd "${_srcdir}"
python setup.py install --root="${pkgdir}" --optimize=1
@@ -85,7 +83,7 @@ package() {
# Do not include the tests/ generated from the install
# rm -Rfv "${pkgdir}"/usr/lib/python*/site-packages/tests
- set +u
+ # set +u # not compatible with msg and makepkg --nocolor
}
set +u