summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2020-04-23 15:36:03 -0400
committerChris Severance2020-04-23 15:36:03 -0400
commit774668701ec25a1d9b41ff1f6b7f83b5898212d0 (patch)
tree9b9f52d1d29a43c0356ededd7f5ab3eebdff1257
parentc79ee60a375ba6ad74c4a51cb15ad3a51adb9212 (diff)
downloadaur-774668701ec25a1d9b41ff1f6b7f83b5898212d0.tar.gz
Update to 1.15.45
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD55
2 files changed, 40 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5be9bf6190e6..769b633771f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Apr 23 19:24:57 UTC 2020
+# Thu Apr 23 19:36:03 UTC 2020
pkgbase = python-botocore-git
pkgdesc = A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3
- pkgver = 1.15.44
+ pkgver = 1.15.45.r6694.g6c73c753d
pkgrel = 1
url = https://github.com/boto/botocore
arch = any
@@ -11,27 +11,21 @@ pkgbase = python-botocore-git
makedepends = python-distribute
makedepends = git
depends = python
- depends = python-wheel>=0.24.0
+ depends = python-dateutil>=2.1
depends = python-jmespath>=0.7.1
- depends = python-jmespath<1.0.0
- depends = python-jsonschema>=2.5.1
+ depends = python-docutils>=0.10
+ depends = python-urllib3>=1.20
depends = python-tox>=2.5.0
- depends = python-tox<3.0.0
- depends = python-dateutil>=2.1
- depends = python-dateutil<3.0.0
depends = python-nose>=1.3.7
depends = python-mock>=1.3.0
+ depends = python-wheel>=0.24.0
depends = python-docutils>=0.10
- depends = python-six>=1.1.0
- depends = python-docutils>=0.10
- depends = python-docutils<0.16
+ depends = python-behave>=1.2.5
+ depends = python-jsonschema>=2.5.1
depends = python-sphinx>=1.1.3
depends = python-guzzle-sphinx-theme>=0.7.10
- depends = python-guzzle-sphinx-theme<0.8
- depends = python-behave>=1.2.5
- depends = python-urllib3>=1.20
- depends = python-urllib3<1.26
- provides = python-botocore=1.15.44
+ depends = python-six>=1.1.0
+ provides = python-botocore=1.15.45
conflicts = python-botocore
options = !strip
source = botocore::git+https://github.com/boto/botocore.git
diff --git a/PKGBUILD b/PKGBUILD
index 9775be91f368..8bd76659d3be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,14 +26,13 @@ behave==1.2.5
jsonschema==2.5.1
#setup.py
-from setuptools import setup, find_packages
-
-
-requires = [
- 'jmespath>=0.7.1,<1.0.0',
- 'docutils>=0.10,<0.16',
- 'python-dateutil>=2.1,<3.0.0',
-]
+[metadata]
+requires-dist =
+ python-dateutil>=2.1,<3.0.0
+ jmespath>=0.7.1,<1.0.0
+ docutils>=0.10,<0.16
+ urllib3>=1.20,<1.25.8; python_version=='3.4'
+ urllib3>=1.20,<1.26; python_version!='3.4'
if sys.version_info[:2] == (3, 4):
@@ -49,35 +48,41 @@ set -u
_pyver="python"
_pybase='botocore'
pkgname="${_pyver}-${_pybase}-git"
-pkgver=1.15.44
+pkgver=1.15.45.r6694.g6c73c753d
pkgrel=1
pkgdesc='A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3'
arch=('any')
url="https://github.com/boto/${_pybase}"
license=('Apache') # Apache License 2.0
_pydepends=( # See setup.py, README.rst, and requirements.txt for version dependencies
- #"${_pyver}-bcdoc<0.15.0" # AUR
- "${_pyver}-wheel>=0.24.0" # AUR ==
- "${_pyver}-jmespath"{'>=0.7.1','<1.0.0'} # AUR == is possible for repositories. Makes upgrades impossible in AUR.
- "${_pyver}-jsonschema>=2.5.1" # COM
- "${_pyver}-tox"{'>=2.5.0','<3.0.0'} # COM == is possible because this is from a repository. Unfortunatley Arch isn"t the primary dev environment for botocore/aws so our packages are likely to be newer.
- "${_pyver}-dateutil"{'>=2.1','<3.0.0'} # COM
- "${_pyver}-nose>=1.3.7" # COM ==
- "${_pyver}-mock>=1.3.0" # COM ==
- "${_pyver}-docutils>=0.10" # COM
- "${_pyver}-six>=1.1.0" # COM This is in the sources but I'm not sure where the version comes from.
- # requirements-docs.txt
- "${_pyver}-docutils"{'>=0.10','<0.16'}
- "${_pyver}-sphinx>=1.1.3" #"${_pyver}-sphinx"{>=1.1.3,<1.3} # COM Arch is already newer. Documentation might not work.
- "${_pyver}-guzzle-sphinx-theme"{'>=0.7.10','<0.8'}
+ # setup.py
+ "${_pyver}-dateutil"'>=2.1' #,'<3.0.0'}
+ "${_pyver}-jmespath"'>=0.7.1' #,'<1.0.0'}
+ "${_pyver}-docutils>=0.10" #,'0.16'}
+ "${_pyver}-urllib3"'>=1.20' #,'<1.26'}
+
+ # requirements.txt
+ "${_pyver}-tox"'>=2.5.0' #,'<3.0.0'}
+ "${_pyver}-nose>=1.3.7"
+ "${_pyver}-mock>=1.3.0"
+ "${_pyver}-wheel>=0.24.0"
+ "${_pyver}-docutils"'>=0.10' #,'<0.16'}
"${_pyver}-behave>=1.2.5"
- "${_pyver}-urllib3"{'>=1.20','<1.26'}
+ "${_pyver}-jsonschema>=2.5.1"
+
+ # requirements-docs.txt
+ "${_pyver}-sphinx"'>=1.1.3' # ,'<1.3'}
+ "${_pyver}-guzzle-sphinx-theme"'>=0.7.10' #,'<0.8'}
+
+ # old but still required
+ #"${_pyver}-bcdoc<0.15.0"
+ "${_pyver}-six>=1.1.0"
)
depends=("${_pyver}" "${_pydepends[@]}")
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
options=('!strip')
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('9ea9a2c975b6e9641c94adc5d550c330d3ad3cdc164772e015d26f51fd639409')
+sha256sums=('3b7dc218a8535918b53784beb0d36e231444e6f20475f50e262662bb38523cc8')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
_srcdir="${_pybase}"