summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-08-13 19:19:34 -0400
committerChris Severance2015-08-13 19:19:34 -0400
commit8ad181c6ef572983168a71a858d6bef0454d8d58 (patch)
treee5172c58972a775dec6826856e36ece9958ddcda
parent0f5903ab07ffcc51d7d0633153deee15e060b30e (diff)
downloadaur-8ad181c6ef572983168a71a858d6bef0454d8d58.tar.gz
Unified botocore and aws-cli
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD102
2 files changed, 78 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bcacc6a9aa4..4d39e049a3af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,26 @@
pkgbase = python-botocore-git
- pkgdesc = A low-level interface to a growing number of Amazon Web Services (AWS). This package is the foundation for AWS-CLI
- pkgver = 1.0.0b1.r1885.61b194d
- pkgrel = 2
+ pkgdesc = A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3
+ pkgver = 1.1.8.r2084.gc47c708
+ pkgrel = 1
url = https://github.com/boto/botocore
arch = any
- license = custom
+ license = Apache
+ makedepends = python-distribute
makedepends = git
- makedepends = python-setuptools
depends = python
- depends = python-six>=1.1.0
+ depends = python-bcdoc<0.15.0
+ depends = python-wheel>=0.24.0
+ depends = python-jmespath>=0.7.1
depends = python-tox>=1.4
depends = python-sphinx>=1.1.3
depends = python-dateutil>=2.1
depends = python-nose>=1.3.0
depends = python-mock>=1.0.1
- depends = python-jmespath
- provides = python-botocore
+ depends = python-six>=1.1.0
+ provides = python-botocore=1.1.8
+ conflicts = python2-botocore
conflicts = python-botocore
- source = git+https://github.com/boto/botocore.git
+ source = botocore::git+https://github.com/boto/botocore.git
sha256sums = SKIP
pkgname = python-botocore-git
diff --git a/PKGBUILD b/PKGBUILD
index eaea59489641..370edca802c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,91 @@
+# Maintainer: Chris Severance aur.severach AatT spamgourmet.com
# Maintainer: jyantis <yantis@yantis.net>
+# This package is designed so that these PKGBUILD are easy to sync with Midnight Commander:
+# aws-cli & aws-cli-git
+# python-botocore & python-botocore-git
+
# Note: the primary use of this package is with aws-cli
-# If you are having problems with aws-cli try aws-cli-git and this package
-# as aws-cli wasn't working with python-botocore after yesterdays update
-pkgname=python-botocore-git
-pkgver=1.0.0b1.r1885.61b194d
-pkgrel=2
-pkgdesc='A low-level interface to a growing number of Amazon Web Services (AWS). This package is the foundation for AWS-CLI'
+set -u
+_pkgname='botocore'
+pkgname="python-${_pkgname}-git"
+pkgver=1.1.8.r2084.gc47c708
+pkgrel=1
+pkgdesc='A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3'
arch=('any')
-url='https://github.com/boto/botocore'
-license=('custom')
-depends=('python'
- 'python-six>=1.1.0'
- 'python-tox>=1.4'
- 'python-sphinx>=1.1.3'
- 'python-dateutil>=2.1'
- 'python-nose>=1.3.0'
- 'python-mock>=1.0.1'
- 'python-jmespath'
- )
-source=('git+https://github.com/boto/botocore.git')
-sha256sums=('SKIP')
-makedepends=('git' 'python-setuptools')
-provides=('python-botocore')
-conflicts=('python-botocore')
+url="https://github.com/boto/${_pkgname}"
+license=('Apache') # Apache License 2.0
+depends=('python' # See setup.py, README.rst, and requirements.txt for version dependencies
+ 'python-bcdoc<0.15.0'
+ 'python-wheel>=0.24.0'
+ 'python-jmespath>=0.7.1'
+ 'python-tox>=1.4'
+ 'python-sphinx>=1.1.3'
+ 'python-dateutil>=2.1' # 'python-dateutil<3.0.0' this is an old requirement
+ 'python-nose>=1.3.0'
+ 'python-mock>=1.0.1'
+ 'python-six>=1.1.0'
+)
+makedepends=('python-distribute') # same as python-setuptools
+conflicts=('python2-botocore')
+source=("${_pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('338fed0119d819a60b2b7cf1a1a38f93603c5f012a2a483b713425816a43a57c')
+if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
+ _srcdir="${_pkgname}"
+ makedepends+=('git')
+ provides+=("${pkgname%-git}=${pkgver%%.r*}")
+ conflicts+=("${pkgname%-git}")
+ source=("${_srcdir}::git+${url}.git")
+ :;sha256sums=('SKIP')
pkgver() {
- cd botocore
- printf "%s." "$(grep "__version__ =" botocore/__init__.py | awk -F\' '{print $2}')"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ set -u
+ cd "${_srcdir}"
+ printf '%s.r%s.g%s' "$(sed -ne "s:__version__ = '\(.*\)'"'$:\1:p' 'botocore/__init__.py')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" # "
+ set +u
}
-
+else
+ _srcdir="${_pkgname}-${pkgver}"
+ _verurl="${url}/releases"
+ _versed="${url#*github.com}/archive/\(.*\)\.tar\.gz" # used with ^...$
+ _veropt='l'
+# Return sorted list of all version numbers available (used by git-aurcheck)
+_version() {
+ curl -s -l "${_verurl}" | _getlinks "${_veropt}" | sed -ne "s:^${_versed}"'$:\1:p' | tr '.' ':' | LC_ALL=C sort -n | tr ':' '.' # 1>&2
+}
+fi
build() {
- cd botocore
+ set -u
+ cd "${_srcdir}"
python setup.py build
+ set +u
}
check() {
- cd botocore
+ set -u
+ cd "${_srcdir}"
python setup.py test --verbose
+ set +u
}
package() {
- cd botocore
-
- # We don't need anything related to git in the package
- rm -rf .git*
+ set -u
+ cd "${_srcdir}"
python setup.py install --root="${pkgdir}" --optimize=1
- # Install License
- install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ msg 'Install Documentation'
+ install -Dpm644 'README.rst' 'requirements.txt' -t "${pkgdir}/usr/share/doc/${pkgname%-git}/"
+
+ msg 'Install LICENSE.'
+ install -Dpm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
- # Install Documentation
- install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+ # Do not include the tests/ generated from the install
+ # rm -Rfv "${pkgdir}"/usr/lib/python*/site-packages/tests
+ set +u
}
+set +u
# vim:set ts=2 sw=2 et: