summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-08-31 19:17:40 -0400
committerChris Severance2015-08-31 19:17:40 -0400
commitd938bc082acab6d05a6689822a08af7fa46b04de (patch)
tree9f2cedb264dfed0721942d9757a86eb078079e44
parent1d950603f9e84b32f115b837cb67e03181642b21 (diff)
downloadaur-d938bc082acab6d05a6689822a08af7fa46b04de.tar.gz
Update to 1.1.12
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD30
2 files changed, 27 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fd0752bfa0f..e4e24a171570 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-botocore-git
pkgdesc = A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3
- pkgver = 1.1.11.r2112.gdc0955c
+ pkgver = 1.1.12.r2115.g22a3f4a
pkgrel = 1
url = https://github.com/boto/botocore
arch = any
@@ -21,7 +21,7 @@ pkgbase = python-botocore-git
depends = python-sphinx>=1.1.3
depends = python-guzzle-sphinx-theme>=0.7.10
depends = python-guzzle-sphinx-theme<0.8
- provides = python-botocore=1.1.11
+ provides = python-botocore=1.1.12
conflicts = python2-botocore
conflicts = python-botocore
source = botocore::git+https://github.com/boto/botocore.git
diff --git a/PKGBUILD b/PKGBUILD
index bc625ba6fd6b..a762644259ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,32 @@
# Note: the primary use of this package is with aws-cli
+# Use mcdiff to watch for changes
+_fn_foobar() {
+local _foobar="
+#requirements-docs.txt
+Sphinx>=1.1.3,<1.3
+guzzle_sphinx_theme>=0.7.10,<0.8
+
+#requirements.txt
+tox==1.4
+python-dateutil>=2.1,<3.0.0
+nose==1.3.0
+mock==1.0.1
+wheel==0.24.0
+docutils>=0.10
+
+#setup.py
+requires = ['jmespath==0.7.1',
+ 'python-dateutil>=2.1,<3.0.0',
+ 'docutils>=0.10']
+"
+}
+
set -u
_pkgname='botocore'
pkgname="python-${_pkgname}-git"
-pkgver=1.1.11.r2112.gdc0955c
+pkgver=1.1.12.r2115.g22a3f4a
pkgrel=1
pkgdesc='A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3'
arch=('any')
@@ -35,7 +57,7 @@ depends=('python' # See setup.py, README.rst, and requirements.txt for version d
makedepends=('python-distribute') # same as python-setuptools
conflicts=('python2-botocore')
source=("${_pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('b4e6edc12177dd4f720259aa7027bab00fb9db2029e40e77e67c552ef9f41132')
+sha256sums=('ed125f41b831e67a4829061172b6dd5efe1cf62568ec0c3bfab90af7a72bf0f6')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
_srcdir="${_pkgname}"
@@ -52,9 +74,7 @@ pkgver() {
}
else
_srcdir="${_pkgname}-${pkgver}"
- _verurl="${url}/releases"
- _versed="${url#*github.com}/archive/\(.*\)\.tar\.gz" # used with ^...$
- _veropt='l'
+ _verwatch=("${url}/releases" "${url#*github.com}/archive/\(.*\)\.tar\.gz" 'l')
fi
build() {