summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2018-11-17 18:39:49 -0500
committerChris Severance2018-11-17 18:39:49 -0500
commite434e3176b4a3f6c187d764a62cf3c11e871bab5 (patch)
treeb535d529e814fba63576dea036bb243b8dc5d954
parent45f0fa1a1fc366115ddaf419f7593c31ea302563 (diff)
downloadaur-e434e3176b4a3f6c187d764a62cf3c11e871bab5.tar.gz
Fix deps
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b17a04b11725..d645d3ac8086 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Nov 17 23:29:46 UTC 2018
+# Sat Nov 17 23:39:49 UTC 2018
pkgbase = python-botocore-git
pkgdesc = A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3
pkgver = 1.12.47.r5279.g8b38eb11
@@ -29,7 +29,7 @@ pkgbase = python-botocore-git
depends = python-guzzle-sphinx-theme<0.8
depends = python-behave>=1.2.5
depends = python-urllib3>=1.20
- depends = python-urllib3<1.24
+ depends = python-urllib3<1.25
provides = python-botocore=1.12.47
conflicts = python-botocore
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index dcaa34a626c0..6b8ec8d7bac2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,18 +26,23 @@ docutils>=0.10
behave==1.2.5
-e git://github.com/boto/jmespath.git@develop#egg=jmespath
jsonschema==2.5.1
-urllib3>=1.20,<1.24
+urllib3>=1.20,<1.23; python_version=="3.3"
+urllib3>=1.20,<1.24; python_version=="2.6"
+urllib3>=1.20,<1.25; python_version=="2.7"
+urllib3>=1.20,<1.25; python_version>="3.4"
#setup.py
from setuptools import setup, find_packages
requires = ['jmespath>=0.7.1,<1.0.0',
- 'docutils>=0.10',
- 'urllib3>=1.20,<1.24']
+ 'docutils>=0.10']
if sys.version_info[:2] == (2, 6):
+ requires.append('python-dateutil>=2.1,<3.0.0')
+
+ requires.append('urllib3>=1.20,<1.25')
"
}
unset -f _fn_foobar
@@ -67,7 +72,7 @@ _pydepends=( # See setup.py, README.rst, and requirements.txt for version depend
"${_pyver}-sphinx>=1.1.3" #"${_pyver}-sphinx"{>=1.1.3,<1.3} # COM Arch is already newer. Documentation might not work.
"${_pyver}-guzzle-sphinx-theme"{'>=0.7.10','<0.8'}
"${_pyver}-behave>=1.2.5"
- "${_pyver}-urllib3"{'>=1.20','<1.24'}
+ "${_pyver}-urllib3"{'>=1.20','<1.25'}
)
depends=("${_pyver}" "${_pydepends[@]}")
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools