summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-09-04 00:34:41 -0400
committerChris Severance2015-09-04 00:34:41 -0400
commitf73584a6f96b8fb7f95c599646e5436bfcb887a9 (patch)
tree66963a31581e25ed17fbac06ee986eeae2fa4348
parentd938bc082acab6d05a6689822a08af7fa46b04de (diff)
downloadaur-f73584a6f96b8fb7f95c599646e5436bfcb887a9.tar.gz
Update to 1.2.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4e24a171570..46f98ce2ba4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-botocore-git
pkgdesc = A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3
- pkgver = 1.1.12.r2115.g22a3f4a
+ pkgver = 1.2.0.r2127.g8723d51
pkgrel = 1
url = https://github.com/boto/botocore
arch = any
@@ -21,7 +21,7 @@ pkgbase = python-botocore-git
depends = python-sphinx>=1.1.3
depends = python-guzzle-sphinx-theme>=0.7.10
depends = python-guzzle-sphinx-theme<0.8
- provides = python-botocore=1.1.12
+ provides = python-botocore=1.2.0
conflicts = python2-botocore
conflicts = python-botocore
source = botocore::git+https://github.com/boto/botocore.git
diff --git a/PKGBUILD b/PKGBUILD
index a762644259ac..6daefec66e01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,18 +23,25 @@ nose==1.3.0
mock==1.0.1
wheel==0.24.0
docutils>=0.10
+-e git://github.com/boto/jmespath.git@develop#egg=jmespath
#setup.py
+from setuptools import setup, find_packages
+
+
requires = ['jmespath==0.7.1',
'python-dateutil>=2.1,<3.0.0',
'docutils>=0.10']
+
+
+if sys.version_info[:2] == (2, 6):
"
}
set -u
_pkgname='botocore'
pkgname="python-${_pkgname}-git"
-pkgver=1.1.12.r2115.g22a3f4a
+pkgver=1.2.0.r2127.g8723d51
pkgrel=1
pkgdesc='A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3'
arch=('any')
@@ -57,7 +64,7 @@ depends=('python' # See setup.py, README.rst, and requirements.txt for version d
makedepends=('python-distribute') # same as python-setuptools
conflicts=('python2-botocore')
source=("${_pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('ed125f41b831e67a4829061172b6dd5efe1cf62568ec0c3bfab90af7a72bf0f6')
+sha256sums=('7c5d263434969ba6d517653879cbe5e1a60533890e9c29bd020a1f79312e0c1d')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
_srcdir="${_pkgname}"