summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfunilrys2019-10-17 22:39:49 +0200
committerfunilrys2019-10-17 22:39:49 +0200
commitbd45574957e2c795e4a0cc93ace6cb4e4e388fc3 (patch)
tree24d1b3bd1aa3ab9310e156bb8fc7cc4873d5718f
downloadaur-bd45574957e2c795e4a0cc93ace6cb4e4e388fc3.tar.gz
Introduction of python-box v3.4.5
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9da21829de2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-box
+ pkgdesc = Advanced Python dictionaries with dot notation access
+ pkgver = 3.4.5
+ pkgrel = 1
+ url = https://github.com/cdgriffith/Boxs
+ arch = any
+ license = MIT
+ provides = python-box
+ source = https://files.pythonhosted.org/packages/source/p/python-box/python-box-3.4.5.tar.gz
+ sha256sums = ff2ccbbc06b9b8cfb4d00e3113079bfcd4a050365ad9aa774cb3003da705ad06
+
+pkgname = python-box
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b7055430657
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Nissar Chababy <contact at funilrys dot com>
+
+pkgname=python-box
+pkgver=3.4.5
+pkgrel=1
+pkgdesc="Advanced Python dictionaries with dot notation access"
+arch=('any')
+url="https://github.com/cdgriffith/Boxs"
+license=('MIT')
+provides=("${pkgname}")
+depends=()
+source=(
+ "https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+)
+sha256sums=(
+ "ff2ccbbc06b9b8cfb4d00e3113079bfcd4a050365ad9aa774cb3003da705ad06"
+)
+
+build() {
+ echo "https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+}