summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Boulay2016-04-08 10:26:30 +0200
committerSimon Boulay2016-04-08 10:26:30 +0200
commit121e75020833b7fe5bd4205fef95717ea8896176 (patch)
tree4b8af7e391cfb45aafb739d8601270436be9b05e
parentd77938477a83652e792427ccf8b6f282bf0ef67c (diff)
downloadaur-121e75020833b7fe5bd4205fef95717ea8896176.tar.gz
Avoid conflict between python2 and python3 packages
Rename breathe-apidoc to breathe-apidoc2 in python2-breathe following sphinx naming scheme.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86c8c61686dc..3544f0aa7541 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-breathe
pkgdesc = An extension to reStructuredText and Sphinx to be able to read and render Doxygen xml output.
pkgver = 4.2.0
- pkgrel = 2
+ pkgrel = 3
url = https://breathe.readthedocs.org/en/latest/
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 5cc8f964027c..8d7c2d339268 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=python-breathe
pkgname=('python-breathe' 'python2-breathe')
pkgver=4.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="An extension to reStructuredText and Sphinx to be able to read and render Doxygen xml output."
arch=('any')
url="https://breathe.readthedocs.org/en/latest/"
@@ -28,4 +28,7 @@ package_python2-breathe() {
cd "breathe2-$pkgver"
python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+
+ # To avoid file conflict with the python3 version
+ mv "$pkgdir/usr/bin/breathe-apidoc" "$pkgdir/usr/bin/breathe-apidoc2"
}