summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Keller2018-05-31 20:38:19 +0200
committerAndré Keller2018-05-31 20:38:19 +0200
commit379792d0362fe5d4763134025f28b46750fdb8d8 (patch)
treeaeffefb5c4b2dee0d6266e6d4f34049e933596f5
downloadaur-379792d0362fe5d4763134025f28b46750fdb8d8.tar.gz
Initial package version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38ab4380b216
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-brother_ql
+ pkgdesc = Python package for the raster language protocol of the Brother QL series label printers
+ pkgver = 0.8.4
+ pkgrel = 1
+ url = https://github.com/pklaus/brother_ql
+ arch = any
+ license = GPL-3.0
+ makedepends = python-setuptools
+ depends = python
+ depends = python-future
+ depends = python-packbits
+ depends = python-pillow
+ source = https://files.pythonhosted.org/packages/source/b/brother_ql/brother_ql-0.8.4.tar.gz
+ sha256sums = d68381949ba6777f38d02fb9bd5db301669d560e4195863e0c396e5afadde6f0
+
+pkgname = python-brother_ql
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7556694f14ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=python-brother_ql
+pkgver=0.8.4
+pkgrel=1
+pkgdesc="Python package for the raster language protocol of the Brother QL series label printers"
+url="https://github.com/pklaus/brother_ql"
+depends=('python' 'python-future' 'python-packbits' 'python-pillow')
+makedepends=('python-setuptools')
+license=('GPL-3.0')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/b/brother_ql/brother_ql-$pkgver.tar.gz")
+sha256sums=('d68381949ba6777f38d02fb9bd5db301669d560e4195863e0c396e5afadde6f0')
+
+build() {
+ cd "$srcdir/brother_ql-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/brother_ql-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}