summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2023-05-13 19:13:17 -0700
committerGI_Jack2023-05-13 19:13:17 -0700
commit8fb6efccb85e16ab7f2752068c6d836197b3524e (patch)
tree7e627e00f558849a29ede951ae1f537d10dfcb44
parent10d7e13d33382b989fb57dbeac1223c4bb923026 (diff)
downloadaur-8fb6efccb85e16ab7f2752068c6d836197b3524e.tar.gz
updated for modern packaging guidelines
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bb54b2bd63b..a03ce68443ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
+# Generated by mksrcinfo(replacement shim) v8
+# Sat May 13 07:13:11 PM PDT 2023
pkgbase = python-bs4
pkgdesc = Beautiful Soup. bs4 name required by CrackMapExec trunk
pkgver = 0.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://pypi.python.org/pypi/bs4/
arch = any
license = custom:unknown
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-beautifulsoup4
source = https://files.pythonhosted.org/packages/source/b/bs4/bs4-0.0.1.tar.gz
sha256sums = 36ecea1fd7cc5c0c6e4a1ff075df26d50da647b75376626cc186e2212886dd3a
pkgname = python-bs4
-
diff --git a/PKGBUILD b/PKGBUILD
index 95e65eeeabb8..8c96584ced62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,22 @@
pkgname='python-bs4'
_pkgname='bs4'
pkgver='0.0.1'
-pkgrel=2
+pkgrel=3
pkgdesc='Beautiful Soup. bs4 name required by CrackMapExec trunk'
arch=('any')
url='https://pypi.python.org/pypi/bs4/'
license=('custom:unknown')
depends=('python' 'python-beautifulsoup4')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('36ecea1fd7cc5c0c6e4a1ff075df26d50da647b75376626cc186e2212886dd3a')
build() {
- cd "$srcdir/${_pkgname}-$pkgver"
-
- python setup.py build
+ cd "$srcdir/${_pkgname}-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/${_pkgname}-$pkgver"
-
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ cd "$srcdir/${_pkgname}-$pkgver"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}
-