summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-12-20 07:11:41 +0000
committerAntonio Rojas2017-12-20 07:11:41 +0000
commit0a020da7768bfd6942ff262e50d1dad69e7c5775 (patch)
tree1b5e65e05a4bb0a987e05733fc85e2943b84ece5
downloadaur-0a020da7768bfd6942ff262e50d1dad69e7c5775.tar.gz
Package python3 version (FS#56777)
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c785c5fe1744
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id: PKGBUILD 274560 2017-12-16 10:45:58Z arojas $
+# Maintainer:
+# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgbase=python-btchip
+pkgname=(python-btchip python2-btchip)
+pkgver=0.1.24
+pkgrel=2
+pkgdesc="Python library to communicate with BTChip dongle"
+arch=('any')
+makedepends=(python-setuptools python2-setuptools)
+optdepends=('btchip-udev: access BTChip as non-root user')
+url="https://github.com/LedgerHQ/btchip-python"
+license=('Apache')
+source=($pkgname-$pkgver.tar.gz::https://github.com/LedgerHQ/btchip-python/archive/v$pkgver.tar.gz)
+sha256sums=('2afab0f326b96bd819e8bc9cb69edc7c55773741a50a5e5a36d224bcfd93a4a2')
+
+prepare() {
+ cp -r btchip-python-$pkgver btchip-python2-$pkgver
+}
+
+build() {
+ cd btchip-python-$pkgver
+ python setup.py build
+
+ cd ../btchip-python2-$pkgver
+ python2 setup.py build
+}
+
+package_python-btchip() {
+ depends=(python-hidapi)
+
+ cd btchip-python-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+package_python2-btchip() {
+ depends=(python2-hidapi)
+
+ cd btchip-python2-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}
+