summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Weiss2017-11-07 08:57:00 -0800
committerMaximilian Weiss2017-11-07 08:57:00 -0800
commit46a452a4b4b3143d4f46cfad91ab5a79ca1c036a (patch)
tree775b990552eb0e860460f47de86b6a8ea71cccc6
parentb8c737252ba9d40ae21d09d09cadd2621e6f3ab6 (diff)
downloadaur-46a452a4b4b3143d4f46cfad91ab5a79ca1c036a.tar.gz
Minor bugfix for getting future tags
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6ad4de554d3..0d3d7b74fd03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-btchip-git
pkgdesc = Python library to communicate with BTChip dongle
pkgver = 0.1.22
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/LedgerHQ/btchip-python
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 8c22bb0db1b1..4f9303b57920 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=python-btchip-git
pkgver=0.1.22
-pkgrel=1
+pkgrel=2
pkgdesc="Python library to communicate with BTChip dongle"
arch=('any')
depends=('python-hidapi')
@@ -19,12 +19,12 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/btchip-python/"
- git describe --abbrev=0 --tags | head -n 1 | sed 's/v//g'
+ git tag -l | tail -n 1 | sed 's/v//g'
}
build() {
cd "$srcdir/btchip-python/"
- git checkout $(git describe --abbrev=0 --tags | head -n 1) > /dev/null 2>&1
+ git checkout $(git tag -l | tail -n 1) > /dev/null 2>&1
python setup.py build
}