summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimofey Titovets2017-02-03 13:15:23 +0300
committerTimofey Titovets2017-02-03 13:15:23 +0300
commitfc68443da238127a2cb4367401fe54939153481f (patch)
treef623b4938a0705042b19e8471db916e94706c70c
downloadaur-fc68443da238127a2cb4367401fe54939153481f.tar.gz
Init
Signed-off-by: Timofey Titovets <nefelim4ag@gmail.com>
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..671a54f70959
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+# Generated by mksrcinfo v8
+# Fri Feb 3 10:14:10 UTC 2017
+pkgbase = python-btrfs
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Jokymon/binstruct
+ arch = any
+ license = GPL3
+ makedepends = python-pip
+
+pkgname = python-btrfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9a8c238fd1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Timofey Titovets <nefelim4ag@gmail.com>
+
+pkgname=python-btrfs
+pkgver=1.0.0
+pkgrel=1
+pkgdesc=""
+arch=('any')
+url="https://github.com/Jokymon/binstruct"
+license=('GPL3')
+depends=()
+makedepends=(python-pip)
+md5sums=()
+#install=.install
+
+package() {
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps btrfs
+ python -O -m compileall "${pkgdir}/usr/lib/python3.5/site-packages/btrfs.py"
+}