summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreg Brown2020-04-03 00:37:35 +0100
committerGreg Brown2020-04-03 00:37:35 +0100
commit7d199ec24b41a12008a13817f5ef192c16aa89b2 (patch)
tree8e21629affab829e3433adfb03836e55bc835f1b
downloadaur-7d199ec24b41a12008a13817f5ef192c16aa89b2.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2ef45f8199b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-buildbot-gitea
+ pkgdesc = Buildbot plugin for integration with Gitea.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/lab132/buildbot-gitea
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = buildbot
+ source = python-buildbot-gitea-1.2.0.tar.gz::https://github.com/lab132/buildbot-gitea/archive/v1.2.0.tar.gz
+ md5sums = 6cdae14b97bd2c65297af41aa42b8b74
+
+pkgname = python-buildbot-gitea
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c54b7e508306
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Greg Brown <greg.brown.00 at outlook dot com>
+_name=buildbot-gitea
+pkgname=python-${_name}
+pkgver=1.2.0
+pkgrel=1
+epoch=
+pkgdesc="Buildbot plugin for integration with Gitea."
+arch=('any')
+url="https://github.com/lab132/buildbot-gitea"
+license=('MIT')
+groups=()
+depends=('buildbot')
+makedepends=('python-setuptools')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz::https://github.com/lab132/$_name/archive/v$pkgver.tar.gz")
+noextract=()
+md5sums=('6cdae14b97bd2c65297af41aa42b8b74')
+validpgpkeys=()
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}