summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli2019-04-15 00:14:56 +0200
committerDenis 'GNUtoo' Carikli2019-04-15 00:25:29 +0200
commite33af7f146eb2178ea3b2a07d30188606e8cbe20 (patch)
treeb6afdae1869cde394d7a9a29248bb828ca095dbc
parentcb9e2975da8c84024df2f254f7423ffcd1788e7f (diff)
downloadaur-e33af7f146eb2178ea3b2a07d30188606e8cbe20.tar.gz
Python package guidelines: follow distutils section
Thanks to elibrokeit on #parabola on Freenode for telling me that I should split build and package functions and how to do it. This is also explained in the the documentation[1] in the distutils section. References: ----------- [1]https://wiki.archlinux.org/index.php/Python_package_guidelines Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5875018d5891..2c4fc40ab2bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-bundlewrap
_pkgname=bundlewrap
pkgver=3.6.1
-pkgrel=1
+pkgrel=2
pkgdesc="Agent-less configuration management"
arch=('any')
url='https://bundlewrap.org/'
@@ -18,7 +18,12 @@ options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
sha256sums=('8c33bbf69750f75a9240c8e9d6bbfb9b6db8c3c62f8527481df0d8bf8c6bbadb')
-package() {
+build(){
cd "$srcdir/bundlewrap-$pkgver"
- python3 setup.py install --root="$pkgdir/" --optimize=1
+ python3 setup.py build
+}
+
+package(){
+ cd "$srcdir/bundlewrap-$pkgver"
+ python3 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}