summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2020-08-23 09:08:28 +0200
committerGrey Christoforo2020-08-23 09:08:28 +0200
commit1621f6de17ec7ccbdac9326e4e15452286a77911 (patch)
tree0c8734dfa322cd2cd2c941df69655ac574dcd8bb
parent83205433e9df3ba24f47af5bdf24f3fbdda42443 (diff)
downloadaur-1621f6de17ec7ccbdac9326e4e15452286a77911.tar.gz
add ezdxf def fail on bad check
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac766bdd282f..d6d3dd13cd7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,7 @@ pkgbase = python-cadquery-git
checkdepends = python-pytest-cov
depends = python-ocp
depends = python
+ depends = python-ezdxf
provides = python-cadquery
conflicts = python-cadquery
source = git+https://github.com/CadQuery/cadquery.git
diff --git a/PKGBUILD b/PKGBUILD
index 31e435bcdb18..8b52a4bb3594 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ url="https://github.com/CadQuery/cadquery"
license=('Apache')
provides=('python-cadquery')
conflicts=('python-cadquery')
-depends=('python-ocp' 'python')
+depends=(python-ocp python python-ezdxf)
checkdepends=('python-pytest' 'python-pytest-cov')
source=("git+https://github.com/CadQuery/cadquery.git")
@@ -23,8 +23,7 @@ pkgver() {
check() {
cd cadquery
- #pytest -v --cov
- pytest -v --cov || true
+ pytest -v --cov
}
build() {