summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-12-31 13:06:38 +0000
committerGrey Christoforo2019-12-31 13:08:18 +0000
commitae64dbb28539749b0cc213979945e7e457906d8c (patch)
tree9dc55a353a30b981adb4c994f36f773d913f3f9b
downloadaur-ae64dbb28539749b0cc213979945e7e457906d8c.tar.gz
initial commit
add srcinfo
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD34
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b5f9c23e602
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-cadquery-git
+ pkgdesc = A parametric CAD scripting framework based on PythonOCC built from git
+ pkgver = 2.0RC1.r61.g74573fc
+ pkgrel = 1
+ url = https://github.com/CadQuery/cadquery
+ arch = any
+ license = Apache
+ makedepends = python-pytest
+ makedepends = python-pytest-cov
+ depends = python-occ-cadquery-git
+ depends = python
+ provides = python-cadquery
+ conflicts = python-cadquery
+ source = git+https://github.com/CadQuery/cadquery.git
+ md5sums = SKIP
+
+pkgname = python-cadquery-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e8466bbe7f67
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+src/
+pkg/
+cadquery/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d35054dcd63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+pkgname=python-cadquery-git
+pkgver=2.0RC1.r61.g74573fc
+pkgrel=1
+pkgdesc="A parametric CAD scripting framework based on PythonOCC built from git"
+arch=('any')
+url="https://github.com/CadQuery/cadquery"
+license=('Apache')
+provides=('python-cadquery')
+conflicts=('python-cadquery')
+depends=('python-occ-cadquery-git' 'python')
+makedepends=('python-pytest' 'python-pytest-cov')
+
+source=("git+https://github.com/CadQuery/cadquery.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd cadquery
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+check() {
+ cd cadquery
+ #pytest -v --cov
+ pytest -v --cov || true
+}
+
+package() {
+ cd cadquery
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+}
+