summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2020-12-17 10:38:24 +0000
committerGreyson Christoforo2020-12-17 10:38:24 +0000
commitef3c5f27e21c0be53cb631212fec2d4d6f9506ed (patch)
tree0819a19a1abc4c6e0c71108b8a8e9262eac02d31
parent78c84abc30a36a2871ecd0ff65da1079f05fa974 (diff)
downloadaur-ef3c5f27e21c0be53cb631212fec2d4d6f9506ed.tar.gz
fix check deps
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31d327f5f39f..e789e3fe1028 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = python-cadquery-git
checkdepends = python-pytest
checkdepends = python-pytest-cov
checkdepends = python-typing_extensions
+ checkdepends = ipython
depends = python
depends = python-ocp
depends = python-ezdxf
diff --git a/PKGBUILD b/PKGBUILD
index 3e280c45a613..7b4a24ae00a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,17 @@ url="https://github.com/CadQuery/cadquery"
license=('Apache')
provides=(python-cadquery)
conflicts=(python-cadquery)
-depends=(python python-ocp python-ezdxf)
-checkdepends=(python-pytest python-pytest-cov python-typing_extensions)
+depends=(
+python
+python-ocp
+python-ezdxf
+)
+checkdepends=(
+python-pytest
+python-pytest-cov
+python-typing_extensions
+ipython
+)
source=("git+https://github.com/CadQuery/cadquery.git")
md5sums=('SKIP')
@@ -24,7 +33,7 @@ pkgver() {
prepare() {
cd cadquery
- # drop text() entirely
+ # drop text() entirely since it appears to be broken in ocp with the latest version of opencascade
curl https://github.com/greyltc/cadquery/commit/48bab8ad9e176590f67980a263262b4c6b0b3198.patch | patch -p1
# loosen volume check restrictions