summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2019-07-12 13:50:59 +0100
committerWill Handley2019-07-12 13:50:59 +0100
commit3e25aec58350fa8fc62e6e7e9633050400a1e8a1 (patch)
treeccab0231b43a227fe42aab02c3af6a0770e740ae
parent9c1febba2349a7b6a768732f1b87c85e5760e2ca (diff)
downloadaur-3e25aec58350fa8fc62e6e7e9633050400a1e8a1.tar.gz
Version 1.0.6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e6769764e71..e84b313357b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-camb
pkgdesc = Code for Anisotropies in the Microwave Background
- pkgver = 1.0.5
- pkgrel = 2
+ pkgver = 1.0.6
+ pkgrel = 1
url = https://github.com/cmbant/CAMB
arch = any
license = custom
@@ -9,8 +9,8 @@ pkgbase = python-camb
depends = python-numpy
depends = gcc-fortran
options = !emptydirs
- source = https://github.com/cmbant/CAMB/archive/1.0.5.tar.gz
- sha256sums = e423a050a0e6740178152f46e7564cba87b8cb1626577cd23b5bf90f9033a06b
+ source = https://github.com/cmbant/CAMB/archive/1.0.6.tar.gz
+ sha256sums = a33eaa474d8b8b7b7a494f9273134cf101d13db993473388cda425913b93793f
pkgname = python-camb
diff --git a/PKGBUILD b/PKGBUILD
index 81b5869041a9..a2728dac0f44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
_modulename=camb
pkgname=python-$_modulename
-pkgver=1.0.5
-pkgrel=2
+pkgver=1.0.6
+pkgrel=1
pkgdesc="Code for Anisotropies in the Microwave Background"
arch=(any)
url="https://github.com/cmbant/CAMB"
@@ -17,13 +17,13 @@ backup=()
options=(!emptydirs)
install=
source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=('e423a050a0e6740178152f46e7564cba87b8cb1626577cd23b5bf90f9033a06b')
+sha256sums=('a33eaa474d8b8b7b7a494f9273134cf101d13db993473388cda425913b93793f')
+check() {
+ cd "$srcdir/CAMB-$pkgver/"
+ python setup.py test
+}
package() {
cd "$srcdir/CAMB-$pkgver/"
python setup.py install --root="$pkgdir/" --optimize=1
install -D -m644 $srcdir/../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-check() {
- cd "$srcdir/CAMB-$pkgver/"
- python setup.py test
-}