summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2022-06-07 21:30:45 +0100
committerWill Handley2022-06-07 21:30:45 +0100
commitf50b797a8d9b868e5c555f69e93a4b7b1b7e9784 (patch)
tree8b1b1d5ce7ea19dfd6f38981663821676758b493
parent2d51a93283f905cbd52a836b93cddf09a1be2c70 (diff)
downloadaur-f50b797a8d9b868e5c555f69e93a4b7b1b7e9784.tar.gz
Updated
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d72735a0ecc4..1b87c5a1b25c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = python-camb
pkgdesc = Code for Anisotropies in the Microwave Background
pkgver = 1.3.2
- pkgrel = 0
+ pkgrel = 3
url = https://github.com/cmbant/CAMB
arch = any
license = custom
makedepends = python-setuptools
options = !emptydirs
- source = https://github.com/cmbant/CAMB/archive/1.3.2.tar.gz
- sha256sums = 38e49aa1e5b856ff2efd909490fde60682287811703fabf418afbc81347cd0c2
+ source = https://files.pythonhosted.org/packages/source/c/camb/camb-1.3.2.tar.gz
+ sha256sums = ae1604e72b10515505ff675a139e1bc1d34b48733974e5feb0c1ce4fbb8b1b00
pkgname = python-camb
- depends = python-numpy
- depends = gcc-fortran
-
diff --git a/PKGBUILD b/PKGBUILD
index 76206bb7ad4d..b4e0624f2576 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-pkgbase=python-camb
-pkgname=("python-camb")
+pkgname=python-camb
+_name=${pkgname#python-}
pkgver=1.3.2
-pkgrel=0
+pkgrel=3
pkgdesc="Code for Anisotropies in the Microwave Background"
arch=(any)
url="https://github.com/cmbant/CAMB"
@@ -15,11 +15,16 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=('38e49aa1e5b856ff2efd909490fde60682287811703fabf418afbc81347cd0c2')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=(ae1604e72b10515505ff675a139e1bc1d34b48733974e5feb0c1ce4fbb8b1b00)
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
- depends=('python-numpy' 'gcc-fortran')
- cd "$srcdir/CAMB-$pkgver/"
- python setup.py install --root="$pkgdir/" --optimize=1
- install -D -m644 $srcdir/../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir/$_name-$pkgver"
+ install -D -m644 $srcdir/../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
+