summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2022-01-13 08:37:02 +0100
committerBlair Bonnett2022-01-13 08:37:02 +0100
commit8efea8e52dc0e77c09795a137f4703f694d4c781 (patch)
tree1c5d91dafc46b69541742fd7219f78369e13bce3
parentd2f6cbf780cb4a6497b7bdb5907610678c5309c6 (diff)
downloadaur-8efea8e52dc0e77c09795a137f4703f694d4c781.tar.gz
Update to 0.20.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12e9805313a0..28a100730fbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-cartopy
pkgdesc = A cartographic Python library with Matplotlib support for visualisation
- pkgver = 0.20.1
+ pkgver = 0.20.2
pkgrel = 1
url = https://scitools.org.uk/cartopy/
arch = x86_64
@@ -26,7 +26,7 @@ pkgbase = python-cartopy
optdepends = python-pyepsg: interface to https://epsg.io
optdepends = python-pykdtree: faster warping of images
optdepends = python-owslib: access OGC clients
- source = https://files.pythonhosted.org/packages/source/c/cartopy/Cartopy-0.20.1.tar.gz
- sha256sums = 91f87b130e2574547a20cd634498df97d797abd12dcfd0235bc0cdbcec8b05e3
+ source = https://files.pythonhosted.org/packages/source/C/Cartopy/Cartopy-0.20.2.tar.gz
+ sha256sums = 4d08c198ecaa50a6a6b109d0f14c070e813defc046a83ac5d7ab494f85599e35
pkgname = python-cartopy
diff --git a/PKGBUILD b/PKGBUILD
index ae06d801598a..5e354517505b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Rich Li <rich@dranek.com>
pkgname=python-cartopy
-pkgver=0.20.1
+pkgver=0.20.2
pkgrel=1
pkgdesc="A cartographic Python library with Matplotlib support for visualisation"
url="https://scitools.org.uk/cartopy/"
@@ -22,21 +22,23 @@ makedepends=('python-setuptools' 'cython' 'python-setuptools-scm')
checkdepends=('python-pytest' 'python-flufl-lock')
license=('LGPL3')
arch=('x86_64')
+
+_pypi=Cartopy
source=(
- "https://files.pythonhosted.org/packages/source/c/cartopy/Cartopy-$pkgver.tar.gz"
+ "https://files.pythonhosted.org/packages/source/${_pypi::1}/$_pypi/$_pypi-$pkgver.tar.gz"
)
sha256sums=(
- '91f87b130e2574547a20cd634498df97d797abd12dcfd0235bc0cdbcec8b05e3'
+ '4d08c198ecaa50a6a6b109d0f14c070e813defc046a83ac5d7ab494f85599e35'
)
build() {
- cd "$srcdir/Cartopy-${pkgver}"
+ cd "$_pypi-$pkgver"
FORCE_CYTHON=1 python setup.py build
}
check() {
local PYVER=$(python -c 'import sys; print("{}.{}".format(*sys.version_info[:2]))')
- cd "$srcdir/Cartopy-${pkgver}/build/lib.linux-$CARCH-$PYVER"
+ cd "$_pypi-$pkgver/build/lib.linux-$CARCH-$PYVER"
# The deselected tests fail an image comparison due to small changes in the
# size and position of text labels.
@@ -46,6 +48,6 @@ check() {
}
package() {
- cd "$srcdir/Cartopy-${pkgver}"
+ cd "$_pypi-$pkgver"
python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1 --skip-build
}