summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2018-12-06 15:17:19 -0800
committerRich Li2018-12-06 15:17:19 -0800
commitf40a803025fcacce7870e8fad31372de57329183 (patch)
treea793f0f70811e9ab20af61579c096e12dd4c9994
parenta06a00a50e30694a6ac9def81e044a2d8eef0b75 (diff)
downloadaur-f40a803025fcacce7870e8fad31372de57329183.tar.gz
Make some optional dependencies required
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc9a4118c5b1..d9b807b752c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-cartopy
pkgdesc = A cartographic python library with matplotlib support for visualisation
pkgver = 0.17.0
- pkgrel = 1
+ pkgrel = 2
url = https://scitools.org.uk/cartopy/docs/latest/
arch = x86_64
license = LGPL3
@@ -14,11 +14,11 @@ pkgbase = python-cartopy
depends = python-shapely
depends = python-pyshp
depends = python-pyproj
+ depends = python-matplotlib
+ depends = python-pillow
+ depends = python-scipy
optdepends = python-fiona: faster shapefile reading
- optdepends = python-matplotlib: generate plots
optdepends = python-gdal: for use with SRTM data
- optdepends = python-pillow
- optdepends = python-scipy
optdepends = python-owslib: access OGC clients
source = python-cartopy-0.17.0.tar.gz::https://github.com/SciTools/cartopy/archive/v0.17.0.tar.gz
md5sums = 9fe063295a9fd854803d3c01a60720d0
diff --git a/PKGBUILD b/PKGBUILD
index daa35aa96560..58c35342948d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,12 @@
# Contributor: Rich Li <rich@dranek.com>
pkgname=python-cartopy
pkgver=0.17.0
-pkgrel=1
+pkgrel=2
pkgdesc="A cartographic python library with matplotlib support for visualisation"
url="https://scitools.org.uk/cartopy/docs/latest/"
-depends=('python-numpy' 'python-six' 'python-shapely' 'python-pyshp' 'python-pyproj')
+depends=('python-numpy' 'python-six' 'python-shapely' 'python-pyshp' 'python-pyproj' 'python-matplotlib' 'python-pillow' 'python-scipy')
optdepends=('python-fiona: faster shapefile reading'
- 'python-matplotlib: generate plots'
'python-gdal: for use with SRTM data'
- 'python-pillow'
- 'python-scipy'
'python-owslib: access OGC clients')
makedepends=('python-setuptools' 'cython')
checkdepends=('python-pytest' 'python-filelock')