summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoffrey2018-06-15 14:21:25 +0000
committerJoffrey2018-06-15 14:21:25 +0000
commitab0ad3461578bf331a90cb34c49b96440cfa288d (patch)
treeff5a0f0949237670ac43ec09940c7edb96329e82
downloadaur-ab0ad3461578bf331a90cb34c49b96440cfa288d.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d2b9357315b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-cas
+ pkgdesc = Python utilities to implement CAS protocol (Central Authentication Service)
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/python-cas/python-cas
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://github.com/python-cas/python-cas/archive/v1.2.0.tar.gz
+ sha256sums = 82e14ee3fb050063ecae43d808b857a1460148ebdb14fcac2cfccbfa41328211
+
+pkgname = python-cas
+ depends = python-six
+ depends = python-requests
+ depends = python-lxml
+
+pkgname = python2-cas
+ depends = python2-six
+ depends = python2-requests
+ depends = python2-lxml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd9288af7ded
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Joffrey <j-off@live.fr>
+
+pkgbase='python-cas'
+pkgname=('python-cas' 'python2-cas')
+pkgver='1.2.0'
+pkgrel=1
+pkgdesc='Python utilities to implement CAS protocol (Central Authentication Service)'
+arch=('any')
+url='https://github.com/python-cas/python-cas'
+license=('MIT')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("https://github.com/python-cas/python-cas/archive/v$pkgver.tar.gz")
+sha256sums=('82e14ee3fb050063ecae43d808b857a1460148ebdb14fcac2cfccbfa41328211')
+
+package_python-cas() {
+ depends=(
+ 'python-six'
+ 'python-requests'
+ 'python-lxml'
+ )
+ cd "$srcdir/python-cas-$pkgver"
+ install -Dm644 './LICENSE.txt' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python './setup.py' install --root="$pkgdir" --optimize=1
+}
+
+package_python2-cas() {
+ depends=(
+ 'python2-six'
+ 'python2-requests'
+ 'python2-lxml'
+ )
+ cd "$srcdir/python-cas-$pkgver"
+ install -Dm644 './LICENSE.txt' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python2 './setup.py' install --root="$pkgdir" --optimize=1
+}