summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2024-04-17 00:02:28 +0800
committerYour Name2024-04-17 00:02:28 +0800
commit5430aaf0a1fba58064eee7130ce0771dbccefacc (patch)
tree3393ec5cd8becda63bb0d22ff2f6d01e441a61f1
parentebe3beb2017f1452e370fdea327d4e99b947071d (diff)
downloadaur-5430aaf0a1fba58064eee7130ce0771dbccefacc.tar.gz
Update to version 0.2.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b0792778829..ad67bb6eda92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = python-casa-formats-io
pkgdesc = Code to handle I/O from/to data in CASA format Resources
- pkgver = 0.2.2
+ pkgver = 0.2.3
pkgrel = 1
url = https://casa-formats-io.readthedocs.io
arch = i686
arch = x86_64
- license = custom:LGPL2
+ license = LGPL-2.0-only
checkdepends = python-pytest-openfiles
makedepends = python-setuptools-scm
makedepends = python-wheel
@@ -16,8 +16,8 @@ pkgbase = python-casa-formats-io
makedepends = python-sphinx-automodapi
makedepends = python-dask
makedepends = python-astropy
- source = https://files.pythonhosted.org/packages/source/c/casa-formats-io/casa-formats-io-0.2.2.tar.gz
- md5sums = 21396ea840b70cbb25debd6a77af23f9
+ source = https://files.pythonhosted.org/packages/source/c/casa_formats_io/casa_formats_io-0.2.3.tar.gz
+ md5sums = a8c9ce1f163d7efb844253f7272990af
pkgname = python-casa-formats-io
depends = python>=3.8
diff --git a/PKGBUILD b/PKGBUILD
index 44afb230da19..fc1c3229d8b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-casa-formats-io
-_pyname=${pkgbase#python-}
-pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=0.2.2
+_pname=${pkgbase#python-}
+_pyname=${_pname//-/_}
+pkgname=("python-${_pname}" "python-${_pname}-doc")
+pkgver=0.2.3
pkgrel=1
pkgdesc="Code to handle I/O from/to data in CASA format Resources"
arch=('i686' 'x86_64')
url="https://casa-formats-io.readthedocs.io"
-license=('custom:LGPL2')
+license=('LGPL-2.0-only')
makedepends=('python-setuptools-scm'
'python-wheel'
'python-build'
@@ -19,7 +20,7 @@ makedepends=('python-setuptools-scm'
'python-astropy')
checkdepends=('python-pytest-openfiles') # astropy and dask already in makedepends. glue-core for pdepend. doctestplus will die for no glue-core
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('21396ea840b70cbb25debd6a77af23f9')
+md5sums=('a8c9ce1f163d7efb844253f7272990af')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
@@ -33,7 +34,7 @@ prepare() {
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python -m build --wheel --no-isolation
+ python -m build --wheel --no-isolation --skip-dependency-check
msg "Building Docs"
PYTHONPATH="../build/lib.linux-${CARCH}-cpython-$(get_pyver)" make -C docs html