summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSibren Vasse2019-02-28 10:55:01 +0100
committerSibren Vasse2019-02-28 10:55:33 +0100
commit96f1103b4bd4fdd73007644e4b8a9b2a9a9bb3bb (patch)
tree00acbce2dd83f599e4ce8efc406528988d50bc3a
parent8a3b02f7ad7379d2856b02deda0f2e26d8d0690b (diff)
downloadaur-96f1103b4bd4fdd73007644e4b8a9b2a9a9bb3bb.tar.gz
Use LICENSE from package and use tarball from github
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD13
3 files changed, 10 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc334ffdb740..cd527d3be943 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = python-casttube
pkgdesc = YouTube chromecast api
pkgver = 0.2.0
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/ur1katz/casttube
arch = any
license = MIT
+ makedepends = python-setuptools
depends = python
depends = python-requests
- depends = python-setuptools
- source = https://files.pythonhosted.org/packages/source/c/casttube/casttube-0.2.0.tar.gz
- source = LICENSE
- sha256sums = f25b3c634efe702896233690f7590e8d6311590910f18dbb763b90419d9ef53c
- sha256sums = 7178b432584adb0a05ef3b47c2f458a8c4ff378fd364b9e2498971d77c7ffa3e
+ source = https://github.com/ur1katz/casttube/archive/0.2.0.tar.gz
+ sha256sums = 5dffe63803914ccd0f311940dc49865c4cd0bd4461f901c27a0ef22b3338cd14
pkgname = python-casttube
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index e05eb86c1ee3..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,21 +0,0 @@
-MIT License
-
-Copyright (c) 2018 Uri Katz
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index e72e150ffd1b..5ea4c4fb4896 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,15 @@
_name='casttube'
pkgname="python-$_name"
pkgver='0.2.0'
-pkgrel=1
+pkgrel=2
pkgdesc="YouTube chromecast api"
url="http://github.com/ur1katz/casttube"
-depends=('python' 'python-requests' 'python-setuptools')
+depends=('python' 'python-requests')
+makedepends=('python-setuptools')
license=('MIT')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/c/${_name}/${_name}-${pkgver}.tar.gz"
- 'LICENSE')
-sha256sums=('f25b3c634efe702896233690f7590e8d6311590910f18dbb763b90419d9ef53c'
- '7178b432584adb0a05ef3b47c2f458a8c4ff378fd364b9e2498971d77c7ffa3e')
+source=("https://github.com/ur1katz/casttube/archive/${pkgver}.tar.gz")
+sha256sums=('5dffe63803914ccd0f311940dc49865c4cd0bd4461f901c27a0ef22b3338cd14')
build() {
cd "${srcdir}/${_name}-${pkgver}"
@@ -20,7 +19,7 @@ build() {
}
package() {
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd "${srcdir}/${_name}-${pkgver}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}