summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2022-01-14 23:19:03 +0300
committerLev Levitsky2022-01-14 23:19:03 +0300
commit7cf87d6a746506974eaf21815364cb7f4724961c (patch)
tree8d6ee41aea2673e2347a6994a9eb3b38ad76a2a2
parent1183abf05334d11c04ae9615293f2f757a6a51a4 (diff)
downloadaur-7cf87d6a746506974eaf21815364cb7f4724961c.tar.gz
1.0.4, py3.10
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bdfec254dd7..83f90b06f32c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = python-catboost
pkgdesc = Fast, scalable, high performance gradient boosting on decision trees
- pkgver = 1.0.3
+ pkgver = 1.0.4
pkgrel = 1
url = https://catboost.ai/
arch = x86_64
license = Apache
makedepends = python-wheel
makedepends = python-pip
- depends = python>=3.9
+ depends = python>=3.10
depends = python-numpy
depends = python-six
depends = python-graphviz
depends = python-plotly
optdepends = python-ipywidgets: visualization in Jupyter
- noextract = catboost-1.0.3-cp39-none-manylinux1_x86_64.whl
+ noextract = catboost-1.0.4-cp310-none-manylinux1_x86_64.whl
options = !emptydirs
- source = https://files.pythonhosted.org/packages/cp39/c/catboost/catboost-1.0.3-cp39-none-manylinux1_x86_64.whl
- sha256sums = 566e89a919149260c4de75c90ceacae688d066975b2a9cf62aed61208d6b4fde
+ source = https://files.pythonhosted.org/packages/cp310/c/catboost/catboost-1.0.4-cp310-none-manylinux1_x86_64.whl
+ sha256sums = d2fb6fdca366890ca71b5a1dee06fb59a78f611a821d2c489c06a10d07749e9f
pkgname = python-catboost
diff --git a/PKGBUILD b/PKGBUILD
index f991770d3fd4..ae2e8e4745e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-catboost
_name=${pkgname#python-}
-_py=cp39
-pkgver=1.0.3
+_py=cp310
+pkgver=1.0.4
pkgrel=1
pkgdesc="Fast, scalable, high performance gradient boosting on decision trees"
arch=('x86_64')
url="https://catboost.ai/"
license=('Apache')
-depends=('python>=3.9' 'python-numpy' 'python-six' 'python-graphviz' 'python-plotly')
+depends=('python>=3.10' 'python-numpy' 'python-six' 'python-graphviz' 'python-plotly')
makedepends=('python-wheel' 'python-pip')
optdepends=('python-ipywidgets: visualization in Jupyter')
options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/$_py/${_name::1}/$_name/${_name/-/_}-$pkgver-$_py-none-manylinux1_x86_64.whl")
-sha256sums=('566e89a919149260c4de75c90ceacae688d066975b2a9cf62aed61208d6b4fde')
+sha256sums=('d2fb6fdca366890ca71b5a1dee06fb59a78f611a821d2c489c06a10d07749e9f')
noextract=("${_name/-/_}-$pkgver-$_py-none-manylinux1_x86_64.whl")
package() {