summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2020-12-27 16:28:28 +0300
committerLev Levitsky2020-12-27 16:28:28 +0300
commitfdd6f3e4c73f70fd8b4a0c35c6305cb7e33124e2 (patch)
tree6abc21d97cfdbf0b43467aa2563e7723754f216f
parente6189d9bf2420065f4eec4b0b0a41a18da47ff01 (diff)
downloadaur-fdd6f3e4c73f70fd8b4a0c35c6305cb7e33124e2.tar.gz
0.24.4, Python 3.9
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6319339a9344..023aeb2010f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-catboost
pkgdesc = Fast, scalable, high performance gradient boosting on decision trees
- pkgver = 0.24.3
+ pkgver = 0.24.4
pkgrel = 1
url = https://catboost.ai/
arch = x86_64
@@ -12,10 +12,10 @@ pkgbase = python-catboost
depends = python-graphviz
depends = python-plotly
optdepends = python-ipywidgets: visualization in Jupyter
- noextract = catboost-0.24.3-cp38-none-manylinux1_x86_64.whl
+ noextract = catboost-0.24.4-cp39-none-manylinux1_x86_64.whl
options = !emptydirs
- source = https://files.pythonhosted.org/packages/cp38/c/catboost/catboost-0.24.3-cp38-none-manylinux1_x86_64.whl
- sha256sums = c07ba6d548e7416e055010655a6234de8cc09578e977575b97b0f46c5a674b45
+ source = https://files.pythonhosted.org/packages/cp39/c/catboost/catboost-0.24.4-cp39-none-manylinux1_x86_64.whl
+ sha256sums = 120dc93fa1ebf3da370528cbf98fac8b5f02d3a7699c8e8a08664cc4a1aafeb0
pkgname = python-catboost
diff --git a/PKGBUILD b/PKGBUILD
index cfda55593fa2..1eb37e63fc7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-catboost
_name=${pkgname#python-}
-_py=cp38
-pkgver=0.24.3
+_py=cp39
+pkgver=0.24.4
pkgrel=1
pkgdesc="Fast, scalable, high performance gradient boosting on decision trees"
arch=('x86_64')
url="https://catboost.ai/"
license=('Apache')
-depends=('python-numpy' 'python-six' 'python-graphviz' 'python-plotly')
+depends=('python>=3.9' 'python-numpy' 'python-six' 'python-graphviz' 'python-plotly')
makedepends=('python-wheel' 'python-pip')
optdepends=('python-ipywidgets: visualization in Jupyter')
options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/$_py/${_name::1}/$_name/${_name/-/_}-$pkgver-$_py-none-manylinux1_x86_64.whl")
-sha256sums=('c07ba6d548e7416e055010655a6234de8cc09578e977575b97b0f46c5a674b45')
+sha256sums=('120dc93fa1ebf3da370528cbf98fac8b5f02d3a7699c8e8a08664cc4a1aafeb0')
noextract=("${_name/-/_}-$pkgver-$_py-none-manylinux1_x86_64.whl")
package() {