summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2019-03-14 17:10:19 +0300
committerDaniel Bershatsky2019-03-14 17:10:19 +0300
commit39a95a118961eaf3b0dda963ec3536ebd28c2d33 (patch)
tree9b84bf78ea1c69ba23ec9fd25bad9fd3176cf64c
parentef1d443f1eae4eb41b31b5cd8be5022bc382bbf6 (diff)
downloadaur-python-catboost-gpu-git.tar.gz
Fix building process in new CatBoost version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d69fc29d187..b232f1819745 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-catboost-gpu-git
pkgdesc = CatBoost is an open-source gradient boosting on decision trees library with categorical features support out of the box.
- pkgver = 0.12.2
- pkgrel = 5
+ pkgver = 0.13
+ pkgrel = 1
epoch = 0
url = https://catboost.yandex
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index a91f60f33231..837ca256e95f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
pkgname=python-catboost-gpu-git
-pkgver=0.12.2
-pkgrel=5
+pkgver=0.13
+pkgrel=1
epoch=0
pkgdesc="CatBoost is an open-source gradient boosting on decision trees library with categorical features support out of the box."
arch=('i686' 'x86_64')
@@ -24,7 +24,7 @@ validpgpkeys=()
pkgver() {
cd "$srcdir/catboost"
- printf "$(git describe | sed -E 's/^v([0-9]+.[0-9]+.[0-9]+).*$/\1/')"
+ printf "$(git describe | sed -E 's/^v([0-9]+\.[0-9]+(\.[0-9]+)?).*$/\1/')"
}
build() {
@@ -45,5 +45,5 @@ build() {
package() {
cd "$srcdir/catboost/catboost/python-package"
- pip3 install --no-deps --prefix $pkgdir/usr catboost-*.whl
+ pip3 install -I --no-deps --prefix $pkgdir/usr catboost-*.whl
}