summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2019-02-23 00:30:11 +0300
committerDaniel Bershatsky2019-02-25 11:36:58 +0300
commitef1d443f1eae4eb41b31b5cd8be5022bc382bbf6 (patch)
treef139b039edf4f181ffab6f1360afae91ef055d91
parent28bbe0514232a11039a78dec14470ece943a349e (diff)
downloadaur-ef1d443f1eae4eb41b31b5cd8be5022bc382bbf6.tar.gz
Clean up build process
- Remove patch for CUDA Runtime 10 support - Fix package version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--cuda10deprecation.patch32
3 files changed, 5 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f02f707de6a2..0d69fc29d187 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-catboost-gpu-git
pkgdesc = CatBoost is an open-source gradient boosting on decision trees library with categorical features support out of the box.
pkgver = 0.12.2
- pkgrel = 3
+ pkgrel = 5
epoch = 0
url = https://catboost.yandex
arch = i686
@@ -13,9 +13,7 @@ pkgbase = python-catboost-gpu-git
optdepends = python-pandas
optdepends = python-ipywidgets
source = catboost::git+https://github.com/catboost/catboost.git
- source = cuda10deprecation.patch
md5sums = SKIP
- md5sums = 44fc5e88fd55a6d19d45fa61cdca6b70
pkgname = python-catboost-gpu-git
diff --git a/PKGBUILD b/PKGBUILD
index ebb016dadb45..a91f60f33231 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
pkgname=python-catboost-gpu-git
pkgver=0.12.2
-pkgrel=3
+pkgrel=5
epoch=0
pkgdesc="CatBoost is an open-source gradient boosting on decision trees library with categorical features support out of the box."
arch=('i686' 'x86_64')
@@ -17,24 +17,19 @@ replaces=()
backup=()
options=()
-source=('catboost::git+https://github.com/catboost/catboost.git'
- 'cuda10deprecation.patch')
-md5sums=('SKIP'
- '44fc5e88fd55a6d19d45fa61cdca6b70')
+source=('catboost::git+https://github.com/catboost/catboost.git')
+md5sums=('SKIP')
validpgpkeys=()
pkgver() {
cd "$srcdir/catboost"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "$(git describe | sed -E 's/^v([0-9]+.[0-9]+.[0-9]+).*$/\1/')"
}
build() {
export YA_CACHE_DIR=/tmp/.ya
- cd "$srcdir/catboost"
- git apply "$srcdir/cuda10deprecation.patch"
-
cd "$srcdir/catboost/catboost/python-package/catboost"
../../../ya make -r \
-DNO_DEBUGINFO \
diff --git a/cuda10deprecation.patch b/cuda10deprecation.patch
deleted file mode 100644
index f09c13659b42..000000000000
--- a/cuda10deprecation.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/catboost/cuda/cuda_lib/cuda_base.h b/catboost/cuda/cuda_lib/cuda_base.h
-index 9c72b8ef9..b20f76137 100644
---- a/catboost/cuda/cuda_lib/cuda_base.h
-+++ b/catboost/cuda/cuda_lib/cuda_base.h
-@@ -126,7 +126,13 @@ namespace NCudaLib {
- cudaPointerAttributes attributes;
- CUDA_SAFE_CALL(cudaPointerGetAttributes(&attributes, (void*)(ptr)));
- //TODO(noxoomo): currently don't distinguish pinned/non-pinned memory
-+#ifndef CUDART_VERSION
-+#error "CUDART_VERSION is not defined: include cuda_runtime_api.h"
-+#elif (CUDART_VERSION >= 10000)
-+ return attributes.type == cudaMemoryTypeHost ? EPtrType::CudaHost : EPtrType::CudaDevice;
-+#else
- return attributes.memoryType == cudaMemoryTypeHost ? EPtrType::CudaHost : EPtrType::CudaDevice;
-+#endif
- }
-
- template <EPtrType From, EPtrType To>
-@@ -258,7 +264,13 @@ namespace NCudaLib {
- inline int GetDeviceForPointer(const T* ptr) {
- cudaPointerAttributes result;
- CUDA_SAFE_CALL(cudaPointerGetAttributes(&result, (const void*)ptr));
-+#ifndef CUDART_VERSION
-+#error "CUDART_VERSION is not defined: include cuda_runtime_api.h"
-+#elif (CUDART_VERSION >= 10000)
-+ CB_ENSURE(result.type == cudaMemoryTypeDevice, "Error: this pointer is not GPU pointer");
-+#else
- CB_ENSURE(result.memoryType == cudaMemoryTypeDevice, "Error: this pointer is not GPU pointer");
-+#endif
- return result.device;
- }
-