summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKartik Mohta2017-06-27 17:00:55 -0400
committerKartik Mohta2017-06-27 17:00:55 -0400
commit9483d0cac4b0b4bf4b8c98780eb152216f8d714d (patch)
tree6768c1c003b18cb1f305a613ff90c26b23e55ee6
parentfb2b122d06c349c7ef8a0f0203b182a162849310 (diff)
downloadaur-9483d0cac4b0b4bf4b8c98780eb152216f8d714d.tar.gz
Fully separate into Python 2 and 3 packages
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
2 files changed, 13 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06a52f784f56..1893c9d67b42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,18 @@
pkgbase = python-catkin_lint
pkgdesc = Check catkin packages for common errors
pkgver = 1.4.16
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fkie/catkin_lint
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/c/catkin_lint/catkin_lint-1.4.16.tar.gz
- md5sums = 6252b8ac505cfc0a87d0064e316db460
-
-pkgname = python-catkin_lint
- depends =
depends = python
depends = python-catkin_pkg
- conflicts = python-catkin-lint
+ provides = python-catkin-lint
conflicts = python2-catkin_lint
- replaces = python-catkin-lint
+ conflicts = python-catkin-lint
+ source = https://files.pythonhosted.org/packages/source/c/catkin_lint/catkin_lint-1.4.16.tar.gz
+ md5sums = 6252b8ac505cfc0a87d0064e316db460
-pkgname = python2-catkin_lint
- depends =
- depends = python2
- depends = python2-catkin_pkg
- conflicts = python2-catkin-lint
- conflicts = python-catkin_lint
- replaces = python2-catkin-lint
+pkgname = python-catkin_lint
diff --git a/PKGBUILD b/PKGBUILD
index f4a141985774..043f49a26116 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,27 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
pkgbase=('python-catkin_lint')
-pkgname=('python-catkin_lint' 'python2-catkin_lint')
+pkgname=('python-catkin_lint')
_module='catkin_lint'
pkgver='1.4.16'
-pkgrel=1
+pkgrel=2
pkgdesc="Check catkin packages for common errors"
url="https://github.com/fkie/catkin_lint"
-depends=()
-makedepends=('python-setuptools' 'python2-setuptools')
+depends=('python' 'python-catkin_pkg')
+provides=('python-catkin-lint')
+conflicts=('python2-catkin_lint' 'python-catkin-lint')
+makedepends=('python-setuptools')
license=('BSD')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/c/catkin_lint/catkin_lint-${pkgver}.tar.gz")
md5sums=('6252b8ac505cfc0a87d0064e316db460')
-prepare() {
- cp -a "${srcdir}/${_module}-${pkgver}"{,-python2}
-}
-
build() {
cd "${srcdir}/${_module}-${pkgver}"
python setup.py build
-
- cd "${srcdir}/${_module}-${pkgver}-python2"
- python2 setup.py build
}
-package_python-catkin_lint() {
- depends+=('python' 'python-catkin_pkg')
- conflicts=('python-catkin-lint' 'python2-catkin_lint')
- replaces=('python-catkin-lint')
+package() {
cd "${srcdir}/${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
-
-package_python2-catkin_lint() {
- depends+=('python2' 'python2-catkin_pkg')
- conflicts=('python2-catkin-lint' 'python-catkin_lint')
- replaces=('python2-catkin-lint')
- cd "${srcdir}/${_module}-${pkgver}-python2"
- python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
-}