summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-11-17 14:32:17 +0800
committerUniversebenzene2022-11-17 14:32:17 +0800
commitef25ad50405b532d27a3985f7b48943f2ec36643 (patch)
treed9bb370ac1706e066b23231a511beba19322a26e
parent3aff7ab9d4f2951f03b821a67013c0d1f6ebce4f (diff)
downloadaur-ef25ad50405b532d27a3985f7b48943f2ec36643.tar.gz
Update to version 2.4.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
-rw-r--r--fix-underline-length.patch47
3 files changed, 84 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d92f58c159f8..81e8e6bd6ae5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,33 @@
pkgbase = python-ccdproc
pkgdesc = Affiliated package for the AstroPy package for basic data reductions of CCD images
- pkgver = 2.3.1
+ pkgver = 2.4.0
pkgrel = 1
url = http://ccdproc.readthedocs.io
arch = any
license = BSD
- checkdepends = python-pytest-astropy
+ checkdepends = python-pytest-astropy-header
+ checkdepends = python-pytest-doctestplus
+ checkdepends = python-astroscrappy
+ checkdepends = python-scikit-image
+ checkdepends = python-reproject
checkdepends = python-memory-profiler
makedepends = python-setuptools-scm
makedepends = python-wheel
makedepends = python-build
makedepends = python-installer
- makedepends = python-scikit-image
- makedepends = python-astroscrappy
- makedepends = python-reproject
makedepends = python-sphinx-astropy
+ makedepends = python-astropy
+ makedepends = python-scipy
makedepends = graphviz
- source = https://files.pythonhosted.org/packages/source/c/ccdproc/ccdproc-2.3.1.tar.gz
- md5sums = 1d2d2e908517132c45128ad327e21b6c
+ source = https://files.pythonhosted.org/packages/source/c/ccdproc/ccdproc-2.4.0.tar.gz
+ source = fix-underline-length.patch
+ md5sums = aecb5216aa0f1c923effc1cadbef76ce
+ md5sums = 714badd0bef757818fda5babe233d235
pkgname = python-ccdproc
depends = python>=3.7
depends = python-scipy
- depends = python-astropy>=4.0.6
+ depends = python-astropy>=4.3
depends = python-scikit-image
depends = python-astroscrappy>=1.0.8
depends = python-reproject>=0.7
diff --git a/PKGBUILD b/PKGBUILD
index f3db738daf52..53b31bb87d46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=python-ccdproc
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=2.3.1
+pkgver=2.4.0
pkgrel=1
pkgdesc="Affiliated package for the AstroPy package for basic data reductions of CCD images"
arch=('any')
@@ -12,14 +12,29 @@ makedepends=('python-setuptools-scm'
'python-wheel'
'python-build'
'python-installer'
- 'python-scikit-image'
- 'python-astroscrappy'
- 'python-reproject'
'python-sphinx-astropy'
+ 'python-astropy'
+ 'python-scipy'
+# 'python-scikit-image'
+# 'python-astroscrappy'
+# 'python-reproject'
'graphviz')
-checkdepends=('python-pytest-astropy' 'python-memory-profiler')
-source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('1d2d2e908517132c45128ad327e21b6c')
+checkdepends=('python-pytest-astropy-header'
+ 'python-pytest-doctestplus'
+ 'python-astroscrappy'
+ 'python-scikit-image'
+ 'python-reproject'
+ 'python-memory-profiler') # psutil required by memory-profiler
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+ 'fix-underline-length.patch')
+md5sums=('aecb5216aa0f1c923effc1cadbef76ce'
+ '714badd0bef757818fda5babe233d235')
+
+prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ patch -Np1 -i "${srcdir}/fix-underline-length.patch"
+}
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -33,11 +48,11 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- pytest || warning "Tests failed"
+ pytest || warning "Tests failed" # -vv --color=yes
}
package_python-ccdproc() {
- depends=('python>=3.7' 'python-scipy' 'python-astropy>=4.0.6' 'python-scikit-image' 'python-astroscrappy>=1.0.8' 'python-reproject>=0.7')
+ depends=('python>=3.7' 'python-scipy' 'python-astropy>=4.3' 'python-scikit-image' 'python-astroscrappy>=1.0.8' 'python-reproject>=0.7')
optdepends=('python-ccdproc-doc: Documentation for CCDPROC')
cd ${srcdir}/${_pyname}-${pkgver}
diff --git a/fix-underline-length.patch b/fix-underline-length.patch
new file mode 100644
index 000000000000..2cb04191dc3b
--- /dev/null
+++ b/fix-underline-length.patch
@@ -0,0 +1,47 @@
+--- a/ccdproc/combiner.py 2022-11-17 06:53:15.000000000 +0800
++++ b/ccdproc/combiner.py 2022-11-17 08:43:12.337111987 +0800
+@@ -59,7 +59,7 @@
+ and weighting used for combining frames.
+
+ Parameters
+- -----------
++ ----------
+ ccd_iter : list or generator
+ A list or generator of CCDData objects that will be combined together.
+
+@@ -224,7 +224,7 @@
+ Nimages-nlow-nhigh pixel values instead of the combination of Nimages.
+
+ Parameters
+- -----------
++ ----------
+ nlow : int or None, optional
+ If not None, the number of low values to reject from the
+ combination.
+@@ -278,7 +278,7 @@
+ """Mask all pixels that are below min_clip or above max_clip.
+
+ Parameters
+- -----------
++ ----------
+ min_clip : float or None, optional
+ If not None, all pixels with values below min_clip will be masked.
+ Default is ``None``.
+@@ -311,7 +311,7 @@
+ high_thresh or lower than that set by low_thresh will be rejected.
+
+ Parameters
+- -----------
++ ----------
+
+ low_thresh : positive float or None, optional
+ Threshold for rejecting pixels that deviate below the baseline
+@@ -708,7 +708,7 @@
+ Convenience function for combining multiple images.
+
+ Parameters
+- -----------
++ ----------
+ img_list : `numpy.ndarray`, list or str
+ A list of fits filenames or `~astropy.nddata.CCDData` objects that will be
+ combined together. Or a string of fits filenames separated by comma