summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2019-10-05 16:37:57 -0400
committerEric Berquist2019-10-05 16:37:57 -0400
commit0639bc2ff930fdf761408a5254067ab1faf0a81c (patch)
treea49a730ee68c06523633f14dd63226c279df92eb
parent04847af868f66518949c3c1fa8889096f245777b (diff)
downloadaur-0639bc2ff930fdf761408a5254067ab1faf0a81c.tar.gz
Version bump: 1.6.1 -> 1.6.2
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
2 files changed, 25 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6cb1d8ae7010..e49dad4621f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = python-cclib
pkgdesc = A library for parsing and interpreting the results of computational chemistry packages.
- pkgver = 1.6.1
+ pkgver = 1.6.2
pkgrel = 1
url = http://cclib.github.io
arch = any
- license = LGPL
- source = https://github.com/cclib/cclib/archive/v1.6.1.tar.gz
- sha256sums = 3a5535d6cbcd6f18f615cc506a018b0153c425b85d2c1319166e75fd93950831
-
-pkgname = python-cclib
- depends = python
+ license = BSD-3-Clause
+ makedepends = python-setuptools
depends = python-numpy
+ depends = python-packaging
+ optdepends = python-openbabel: for generating `OBMol`s of results
+ optdepends = python-biopython: for generating `BioPython.Atom`s of parsed results
+ optdepends = python-pandas: for generating DataFrames of parsed results
+ optdepends = python-periodictable: for calculating properties of nuclear configurations
+ optdepends = python-scipy: for calculating properties of nuclear configurations
+ source = https://github.com/cclib/cclib/archive/v1.6.2.tar.gz
+ sha256sums = ece7b34a487f7483763ef997fa527b8a8c3e1963796df0a9dbf3bab85a686338
-pkgname = python2-cclib
- depends = python2
- depends = python2-numpy
+pkgname = python-cclib
diff --git a/PKGBUILD b/PKGBUILD
index 0a49a38ae14a..c6c4459d6843 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,25 @@
# Maintainer: Eric Berquist <eric dot berquist at gmail dot com>
_name="cclib"
-pkgbase="python-${_name}"
-pkgname=("python-${_name}" "python2-${_name}")
-pkgver="1.6.1"
+pkgname="python-${_name}"
+pkgver="1.6.2"
pkgrel="1"
pkgdesc="A library for parsing and interpreting the results of computational chemistry packages."
arch=("any")
url="http://cclib.github.io"
-license=("LGPL")
+license=("BSD-3-Clause")
+makedepends=("python-setuptools")
+depends=("python-numpy" "python-packaging")
+optdepends=('python-openbabel: for generating `OBMol`s of results'
+ 'python-biopython: for generating `BioPython.Atom`s of parsed results'
+ 'python-pandas: for generating DataFrames of parsed results'
+ 'python-periodictable: for calculating properties of nuclear configurations'
+ 'python-scipy: for calculating properties of nuclear configurations')
source=("https://github.com/${_name}/${_name}/archive/v${pkgver}.tar.gz")
-sha256sums=('3a5535d6cbcd6f18f615cc506a018b0153c425b85d2c1319166e75fd93950831')
+sha256sums=('ece7b34a487f7483763ef997fa527b8a8c3e1963796df0a9dbf3bab85a686338')
-package_python-cclib() {
- depends=("python" "python-numpy")
+package() {
cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
- find "${pkgdir}" -name "*.pyc" -delete
- find "${pkgdir}" -type d -empty -delete
-}
-
-package_python2-cclib() {
- depends=("python2" "python2-numpy")
- cd "${srcdir}/${_name}-${pkgver}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
- find "${pkgdir}" -name "*.pyc" -delete
- find "${pkgdir}" -type d -empty -delete
- # Keep /usr/bin driver scripts, but not the default name.
- cd "${pkgdir}/usr/bin"
- for i in $(ls); do
- mv "${i}" "${i}2"
- done
+ install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}