summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2022-01-02 12:46:27 -0500
committerEric Berquist2022-01-02 12:46:27 -0500
commit2fa584fd96a044d22eba6d93131784daba1dba74 (patch)
tree3408c3ed37a6ae2c7c721440a3c2144b7a234811
parentebafa2bffcc9b2a67739bce31e1455c5317edbd0 (diff)
downloadaur-2fa584fd96a044d22eba6d93131784daba1dba74.tar.gz
Version bump: 1.6.2 -> 1.7.1
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD11
3 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca05eaa221c5..de94c2b6e40d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-cclib
pkgdesc = A library for parsing and interpreting the results of computational chemistry packages.
- pkgver = 1.6.2
- pkgrel = 2
+ pkgver = 1.7.1
+ pkgrel = 1
url = http://cclib.github.io
arch = any
license = BSD-3-Clause
@@ -9,12 +9,11 @@ pkgbase = python-cclib
depends = python-numpy
depends = python-packaging
depends = python-periodictable
+ depends = python-scipy
optdepends = python-openbabel: for generating `OBMol`s of results
optdepends = python-biopython: for generating `BioPython.Atom`s of parsed results
optdepends = python-pandas: for generating DataFrames of parsed results
- optdepends = python-scipy: for calculating properties of nuclear configurations
- source = https://github.com/cclib/cclib/archive/v1.6.2.tar.gz
- sha256sums = ece7b34a487f7483763ef997fa527b8a8c3e1963796df0a9dbf3bab85a686338
+ source = https://github.com/cclib/cclib/archive/v1.7.1.tar.gz
+ sha256sums = eaf351db14aeba60708b42f7cfa7d2164b93bf6de259d8e224a469065e139564
pkgname = python-cclib
-
diff --git a/.gitignore b/.gitignore
index dec787d8c50e..7b49216358a9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,10 @@
pkg/
src/
*.xz
+*.zst
+
+# mkarchchroot files
+*.log
# source files
*.gz
diff --git a/PKGBUILD b/PKGBUILD
index 8c49add8585e..871c09c47316 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,19 @@
_name="cclib"
pkgname="python-${_name}"
-pkgver=1.6.2
-pkgrel=2
+pkgver=1.7.1
+pkgrel=1
pkgdesc="A library for parsing and interpreting the results of computational chemistry packages."
arch=("any")
url="http://cclib.github.io"
license=("BSD-3-Clause")
makedepends=("python-setuptools")
-depends=("python-numpy" "python-packaging" "python-periodictable")
+depends=("python-numpy" "python-packaging" "python-periodictable" "python-scipy")
optdepends=('python-openbabel: for generating `OBMol`s of results'
'python-biopython: for generating `BioPython.Atom`s of parsed results'
- 'python-pandas: for generating DataFrames of parsed results'
- 'python-scipy: for calculating properties of nuclear configurations')
+ 'python-pandas: for generating DataFrames of parsed results')
source=("https://github.com/${_name}/${_name}/archive/v${pkgver}.tar.gz")
-sha256sums=('ece7b34a487f7483763ef997fa527b8a8c3e1963796df0a9dbf3bab85a686338')
+sha256sums=('eaf351db14aeba60708b42f7cfa7d2164b93bf6de259d8e224a469065e139564')
package() {
cd "${srcdir}/${_name}-${pkgver}"