summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2015-06-17 11:11:37 -0400
committerEric Berquist2015-06-17 11:11:37 -0400
commit94e0765076f50669a7328498f8e9a8db633abfc9 (patch)
tree42a84fdb969bd177f2ad4b5deb1a2cacc49c5998
downloadaur-94e0765076f50669a7328498f8e9a8db633abfc9.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..880d2b7b48aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-cclib
+ pkgdesc = A library for parsing and interpreting the results of computational chemistry packages.
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://cclib.github.io
+ arch = any
+ license = LGPL
+ source = https://github.com/cclib/cclib/releases/download/v1.3.1/cclib-1.3.1.tar.gz
+ sha256sums = 2a5270cc575008e618f485265e6e7a41c5072f8d9a89fc89e0eadd13933d69f1
+
+pkgname = python-cclib
+ depends = python
+ depends = python-numpy
+
+pkgname = python2-cclib
+ depends = python2
+ depends = python2-numpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..445b5a8a8f7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Eric Berquist <eric dot berquist at gmail dot com>
+
+_name="cclib"
+pkgbase="python-${_name}"
+pkgname=("python-${_name}" "python2-${_name}")
+pkgver="1.3.1"
+pkgrel="1"
+pkgdesc="A library for parsing and interpreting the results of computational chemistry packages."
+arch=("any")
+url="http://cclib.github.io"
+license=("LGPL")
+source=("https://github.com/${_name}/${_name}/releases/download/v${pkgver}/cclib-${pkgver}.tar.gz")
+sha256sums=('2a5270cc575008e618f485265e6e7a41c5072f8d9a89fc89e0eadd13933d69f1')
+
+package_python-cclib() {
+ depends=("python" "python-numpy")
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ find "${pkgdir}" -name "*.pyc" -delete
+ find "${pkgdir}" -type d -empty -delete
+}
+
+package_python2-cclib() {
+ depends=("python2" "python2-numpy")
+ cd "${srcdir}/${_name}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ find "${pkgdir}" -name "*.pyc" -delete
+ find "${pkgdir}" -type d -empty -delete
+ # Keep /usr/bin driver scripts, but not the default name.
+ cd "${pkgdir}/usr/bin"
+ for i in $(ls); do
+ mv "${i}" "${i}2"
+ done
+}