summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2024-02-24 16:02:28 -0500
committerEric Berquist2024-02-24 16:02:28 -0500
commita20076b246d18aa45b9d9d7c5a41f3385e01d8d6 (patch)
tree24c529475a231b3b33119f8747dd6760ca391d77
parent22f0104ff5d092ec5e93114b0863a572c92fb956 (diff)
downloadaur-a20076b246d18aa45b9d9d7c5a41f3385e01d8d6.tar.gz
Update for pyproject.toml-based build
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 53 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f69bb3db940a..2fbe2ef6521f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,32 @@
pkgbase = python-cclib-git
pkgdesc = A library for parsing and interpreting the results of computational chemistry packages. (git version)
- pkgver = 1.7.2.r3755.5a881638
+ pkgver = 1.8.1.r4748.6832e465
pkgrel = 1
url = http://cclib.github.io
arch = any
license = BSD-3-Clause
- makedepends = python-setuptools
+ checkdepends = psi4
+ checkdepends = python-biopython
+ checkdepends = python-iodata
+ checkdepends = python-pyquante2
+ checkdepends = python-pyscf
+ checkdepends = python-pytest
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-packaging
depends = python-periodictable
depends = python-scipy
- optdepends = python-openbabel: for generating `OBMol`s of results
+ optdepends = psi4: for Psi4 bridge
+ optdepends = python-ase: for ASE bridge
optdepends = python-biopython: for generating `BioPython.Atom`s of parsed results
+ optdepends = python-iodata: for reading proatom densities from horton
+ optdepends = python-openbabel: for generating `OBMol`s of results
optdepends = python-pandas: for generating DataFrames of parsed results
+ optdepends = python-pyquante2: for computing grid-based quantities with cube output
+ optdepends = python-pyscf: for PySCF bridge
provides = python-cclib
conflicts = python-cclib
source = git+https://github.com/cclib/cclib
diff --git a/PKGBUILD b/PKGBUILD
index ea23a811594c..324928a4387a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,58 @@
_name="cclib"
pkgname="python-${_name}-git"
-pkgver=1.7.2.r3755.5a881638
+pkgver=1.8.1.r4748.6832e465
pkgrel=1
pkgdesc="A library for parsing and interpreting the results of computational chemistry packages. (git version)"
arch=("any")
url="http://cclib.github.io"
license=("BSD-3-Clause")
-makedepends=("python-setuptools" "git")
+makedepends=("git"
+ "python-build"
+ "python-installer"
+ "python-setuptools"
+ "python-wheel")
+checkdepends=("psi4"
+ "python-biopython"
+ "python-iodata"
+ "python-pyquante2"
+ "python-pyscf"
+ "python-pytest")
depends=("python-packaging" "python-periodictable" "python-scipy")
-optdepends=('python-openbabel: for generating `OBMol`s of results'
+optdepends=('psi4: for Psi4 bridge'
+ 'python-ase: for ASE bridge'
'python-biopython: for generating `BioPython.Atom`s of parsed results'
- 'python-pandas: for generating DataFrames of parsed results')
+ 'python-iodata: for reading proatom densities from horton'
+ 'python-openbabel: for generating `OBMol`s of results'
+ 'python-pandas: for generating DataFrames of parsed results'
+ 'python-pyquante2: for computing grid-based quantities with cube output'
+ 'python-pyscf: for PySCF bridge')
provides=("python-${_name}")
conflicts=("python-${_name}")
source=("git+https://github.com/${_name}/${_name}")
sha256sums=('SKIP')
+prepare() {
+ git -C "${srcdir}/${_name}" clean -dfx
+}
+
+build() {
+ cd "${srcdir}/${_name}"
+ python -m build --wheel --no-isolation
+}
+
package() {
cd "${srcdir}/${_name}"
- python setup.py install --root="${pkgdir}" --optimize=1
- install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
}
+# Requires many heavy dependencies
+# check() {
+# cd "${srcdir}/${_name}"
+# python -m pytest
+# }
+
pkgver() {
cd "${srcdir}/${_name}"
_parent_ver=$(git describe --tags --abbrev=0 | tr -d v)