summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2019-10-05 16:51:41 -0400
committerEric Berquist2019-10-05 16:51:41 -0400
commitb335651b81df6260fe70a3170d2620665dcb64f3 (patch)
tree419aef8353ae6e914b883169c48a8d73808da1a9
parentdde112648f1426566242e7b7934bb6df7323f010 (diff)
downloadaur-b335651b81df6260fe70a3170d2620665dcb64f3.tar.gz
Stop providing a Python 2 package
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD43
2 files changed, 28 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9eb9e597d81f..741c43c8ae7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
-# Generated by mksrcinfo v8
-# Sat May 12 02:28:55 UTC 2018
pkgbase = python-cclib-git
pkgdesc = A library for parsing and interpreting the results of computational chemistry packages. (git version)
- pkgver = 1.5.4.r2295.1e3f6c58
+ pkgver = 1.6.2.r2833.5605bdd9
pkgrel = 1
url = http://cclib.github.io
arch = any
- license = LGPL
+ license = BSD-3-Clause
+ makedepends = python-setuptools
makedepends = git
- source = git+https://github.com/cclib/cclib
- sha256sums = SKIP
-
-pkgname = python-cclib-git
- depends = python
depends = python-numpy
+ depends = python-packaging
+ optdepends = python-openbabel: for generating `OBMol`s of results
+ optdepends = python-biopython: for generating `BioPython.Atom`s of parsed results
+ optdepends = python-pandas: for generating DataFrames of parsed results
+ optdepends = python-periodictable: for calculating properties of nuclear configurations
+ optdepends = python-scipy: for calculating properties of nuclear configurations
provides = python-cclib
conflicts = python-cclib
+ source = git+https://github.com/cclib/cclib
+ md5sums = SKIP
-pkgname = python2-cclib-git
- depends = python2
- depends = python2-numpy
- provides = python2-cclib
+pkgname = python-cclib-git
diff --git a/PKGBUILD b/PKGBUILD
index 6e8681df8b54..8b6a1b758a98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,30 @@
# Maintainer: Eric Berquist <eric dot berquist at gmail dot com>
_name="cclib"
-pkgbase="python-${_name}-git"
-pkgname=("python-${_name}-git" "python2-${_name}-git")
-pkgver=1.5.4.r2295.1e3f6c58
+pkgname="python-${_name}-git"
+pkgver=1.6.2.r2833.5605bdd9
pkgrel=1
pkgdesc="A library for parsing and interpreting the results of computational chemistry packages. (git version)"
arch=("any")
url="http://cclib.github.io"
-license=("LGPL")
-makedepends=("git")
+license=("BSD-3-Clause")
+makedepends=("python-setuptools" "git")
+depends=("python-numpy" "python-packaging")
+optdepends=('python-openbabel: for generating `OBMol`s of results'
+ 'python-biopython: for generating `BioPython.Atom`s of parsed results'
+ 'python-pandas: for generating DataFrames of parsed results'
+ 'python-periodictable: for calculating properties of nuclear configurations'
+ 'python-scipy: for calculating properties of nuclear configurations')
+provides=("python-${_name}")
+conflicts=("python-${_name}")
source=("git+https://github.com/${_name}/${_name}")
-sha256sums=('SKIP')
+md5sums=('SKIP')
-package_python-cclib-git() {
- depends=("python" "python-numpy")
- provides=("python-cclib")
- conflicts=("python-cclib")
- cd "${srcdir}/${_name}"
- python setup.py install --root="${pkgdir}" --optimize=1
- find "${pkgdir}" -name "*.pyc" -delete
- find "${pkgdir}" -type d -empty -delete
-}
-package_python2-cclib-git() {
- depends=("python2" "python2-numpy")
- provides=("python2-cclib")
- conflics=("python2-cclib")
+package() {
cd "${srcdir}/${_name}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
- find "${pkgdir}" -name "*.pyc" -delete
- find "${pkgdir}" -type d -empty -delete
- # Keep /usr/bin driver scripts, but not the default name.
- cd "${pkgdir}/usr/bin"
- for i in $(ls); do
- mv "${i}" "${i}2"
- done
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}
pkgver() {