summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2019-12-24 08:36:01 -0500
committerEric Berquist2019-12-24 08:36:01 -0500
commitbf5ecf3e47131c6b9b88b005f1c2514f30a42d05 (patch)
treefc2d03b9bc03138edbb17b429381e51df4ac0e8d
parentb335651b81df6260fe70a3170d2620665dcb64f3 (diff)
downloadaur-bf5ecf3e47131c6b9b88b005f1c2514f30a42d05.tar.gz
Add periodictable dependency
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 741c43c8ae7d..737a59300b36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-cclib-git
pkgdesc = A library for parsing and interpreting the results of computational chemistry packages. (git version)
- pkgver = 1.6.2.r2833.5605bdd9
- pkgrel = 1
+ pkgver = 1.6.3.r2939.8ecf965c
+ pkgrel = 2
url = http://cclib.github.io
arch = any
license = BSD-3-Clause
@@ -9,10 +9,10 @@ pkgbase = python-cclib-git
makedepends = git
depends = python-numpy
depends = python-packaging
+ depends = python-periodictable
optdepends = python-openbabel: for generating `OBMol`s of results
optdepends = python-biopython: for generating `BioPython.Atom`s of parsed results
optdepends = python-pandas: for generating DataFrames of parsed results
- optdepends = python-periodictable: for calculating properties of nuclear configurations
optdepends = python-scipy: for calculating properties of nuclear configurations
provides = python-cclib
conflicts = python-cclib
diff --git a/PKGBUILD b/PKGBUILD
index 8b6a1b758a98..afe2a86c67fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,17 @@
_name="cclib"
pkgname="python-${_name}-git"
-pkgver=1.6.2.r2833.5605bdd9
-pkgrel=1
+pkgver=1.6.3.r2939.8ecf965c
+pkgrel=2
pkgdesc="A library for parsing and interpreting the results of computational chemistry packages. (git version)"
arch=("any")
url="http://cclib.github.io"
license=("BSD-3-Clause")
makedepends=("python-setuptools" "git")
-depends=("python-numpy" "python-packaging")
+depends=("python-numpy" "python-packaging" "python-periodictable")
optdepends=('python-openbabel: for generating `OBMol`s of results'
'python-biopython: for generating `BioPython.Atom`s of parsed results'
'python-pandas: for generating DataFrames of parsed results'
- 'python-periodictable: for calculating properties of nuclear configurations'
'python-scipy: for calculating properties of nuclear configurations')
provides=("python-${_name}")
conflicts=("python-${_name}")