summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Botting2017-10-30 10:24:12 +1100
committerAndy Botting2017-10-30 10:24:12 +1100
commit45c91c99c8bbb8ba4cb34d9627cdeec8a69b1e0f (patch)
treef10c0b3549bb07e37b92186e60bdbe44fbbe09f8
parent9fa9b8ad9dec47ce1bce966c55768ba72c933648 (diff)
downloadaur-45c91c99c8bbb8ba4cb34d9627cdeec8a69b1e0f.tar.gz
Update to v2.9.0
-rw-r--r--.SRCINFO44
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD107
3 files changed, 105 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a77385cba209..a18d002fd57b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,51 @@
-# Generated by mksrcinfo v8
-# Fri Feb 26 22:40:44 UTC 2016
pkgbase = python-ceilometerclient
pkgdesc = Python client library for Ceilometer
- pkgver = 2.3.0
+ pkgver = 2.9.0
pkgrel = 1
- url = https://launchpad.net/python-ceilometerclient
+ url = http://docs.openstack.org/developer/python-ceilometerclient/
arch = any
license = Apache
+ checkdepends = python-pbr
+ checkdepends = python2-pbr
+ checkdepends = python-iso8601
+ checkdepends = python-iso8601
+ checkdepends = python-keystoneauth1
+ checkdepends = python2-keystoneauth1
+ checkdepends = python-oslo-i18n
+ checkdepends = python2-oslo-i18n
+ checkdepends = python-oslo-serialization
+ checkdepends = python2-oslo-serialization
+ checkdepends = python-oslo-utils
+ checkdepends = python2-oslo-utils
+ checkdepends = python-prettytable
+ checkdepends = python2-prettytable
+ checkdepends = python-requests
+ checkdepends = python2-requests
+ checkdepends = python-six
+ checkdepends = python2-six
+ checkdepends = python-stevedore
+ checkdepends = python2-stevedore
+ checkdepends = python-mock
+ checkdepends = python2-mock
+ checkdepends = python-subunit
+ checkdepends = python2-subunit
+ checkdepends = python-tempest
+ checkdepends = python-testrepository
+ checkdepends = python2-testrepository
+ makedepends = git
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://pypi.python.org/packages/source/p/python-ceilometerclient/python-ceilometerclient-2.3.0.tar.gz
- sha256sums = a2a599619dee58bfc7715c8253ae9642053689d43f4f334ffc85285d56ef7596
+ source = git+https://git.openstack.org/openstack/python-ceilometerclient#tag=2.9.0
+ md5sums = SKIP
pkgname = python-ceilometerclient
depends = python-pbr
depends = python-iso8601
+ depends = python-keystoneauth1
depends = python-oslo-i18n
depends = python-oslo-serialization
depends = python-oslo-utils
depends = python-prettytable
- depends = python-keystoneauth1
- depends = python-keystoneclient
depends = python-requests
depends = python-six
depends = python-stevedore
@@ -28,12 +53,11 @@ pkgname = python-ceilometerclient
pkgname = python2-ceilometerclient
depends = python2-pbr
depends = python2-iso8601
+ depends = python2-keystoneauth1
depends = python2-oslo-i18n
depends = python2-oslo-serialization
depends = python2-oslo-utils
depends = python2-prettytable
- depends = python2-keystoneauth1
- depends = python2-keystoneclient
depends = python2-requests
depends = python2-six
depends = python2-stevedore
diff --git a/.gitignore b/.gitignore
index 3317ac6609e8..05c6d4d4c97b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
-/pkg/
-/src/
-/*.tar.*
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 63eb1cb365d9..4d27dced540a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,81 @@
-# Maintainer: Christoph Gysin <christoph.gysin@gmail.com>
+# Maintainer: Andy Botting <andy@andybotting.com>
pkgname=('python-ceilometerclient'
'python2-ceilometerclient')
-pkgver='2.3.0'
+pkgver='2.9.0'
pkgrel='1'
pkgdesc='Python client library for Ceilometer'
arch=('any')
-url='https://launchpad.net/python-ceilometerclient'
+url="http://docs.openstack.org/developer/${pkgname}/"
license=('Apache')
-source=("https://pypi.python.org/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('a2a599619dee58bfc7715c8253ae9642053689d43f4f334ffc85285d56ef7596')
-
-makedepends=('python-setuptools'
+makedepends=('git'
+ 'python-setuptools'
'python2-setuptools')
+checkdepends=('python-pbr' 'python2-pbr'
+ 'python-iso8601' 'python-iso8601'
+ 'python-keystoneauth1' 'python2-keystoneauth1'
+ 'python-oslo-i18n' 'python2-oslo-i18n'
+ 'python-oslo-serialization' 'python2-oslo-serialization'
+ 'python-oslo-utils' 'python2-oslo-utils'
+ 'python-prettytable' 'python2-prettytable'
+ 'python-requests' 'python2-requests'
+ 'python-six' 'python2-six'
+ 'python-stevedore' 'python2-stevedore'
+ 'python-mock' 'python2-mock'
+ 'python-subunit' 'python2-subunit'
+ 'python-tempest'
+ 'python-testrepository' 'python2-testrepository')
+source=("git+https://git.openstack.org/openstack/${pkgname}#tag=${pkgver}")
+md5sums=('SKIP')
+
+prepare() {
+ cp -a "${srcdir}/${pkgname}"{,-py2}
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py build
+
+ cd "${srcdir}/${pkgname}-py2"
+ python2 setup.py build
+}
+
+check() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py testr
+
+ cd "${srcdir}/${pkgname}-py2"
+ PYTHON=python2 python2 setup.py testr
+}
package_python-ceilometerclient() {
- depends=('python-pbr'
- 'python-iso8601'
- 'python-oslo-i18n'
- 'python-oslo-serialization'
- 'python-oslo-utils'
- 'python-prettytable'
- 'python-keystoneauth1'
- 'python-keystoneclient'
- 'python-requests'
- 'python-six'
- 'python-stevedore')
- cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py \
- install \
- --root="${pkgdir}" \
- --optimize=1
+ depends=('python-pbr'
+ 'python-iso8601'
+ 'python-keystoneauth1'
+ 'python-oslo-i18n'
+ 'python-oslo-serialization'
+ 'python-oslo-utils'
+ 'python-prettytable'
+ 'python-requests'
+ 'python-six'
+ 'python-stevedore')
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1
}
package_python2-ceilometerclient() {
- depends=('python2-pbr'
- 'python2-iso8601'
- 'python2-oslo-i18n'
- 'python2-oslo-serialization'
- 'python2-oslo-utils'
- 'python2-prettytable'
- 'python2-keystoneauth1'
- 'python2-keystoneclient'
- 'python2-requests'
- 'python2-six'
- 'python2-stevedore')
- cd "${srcdir}/python-ceilometerclient-${pkgver}"
- python2 setup.py \
- install \
- --root="${pkgdir}" \
- --optimize=1
- mv "${pkgdir}"/usr/bin/ceilometer{,2}
+ depends=('python2-pbr'
+ 'python2-iso8601'
+ 'python2-keystoneauth1'
+ 'python2-oslo-i18n'
+ 'python2-oslo-serialization'
+ 'python2-oslo-utils'
+ 'python2-prettytable'
+ 'python2-requests'
+ 'python2-six'
+ 'python2-stevedore')
+ cd "${srcdir}/python-ceilometerclient-py2"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
}
+
+# vim:set ts=2 sw=2 et: