summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Botting2019-05-11 16:31:43 +1000
committerAndy Botting2019-05-11 16:31:43 +1000
commit5a475b72cecc35109c5d5c87ed4eaeb4c4532728 (patch)
tree5857cc092519996ee798f07da746c1fe388a5251
parent8e8ae862f39d1398824d2c7faf7ea44781bc65a1 (diff)
downloadaur-5a475b72cecc35109c5d5c87ed4eaeb4c4532728.tar.gz
Update to v2.9.1-1
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD81
2 files changed, 23 insertions, 107 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c955befeb747..7bd3d710dbcb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,43 +1,14 @@
pkgbase = python-ceilometerclient
pkgdesc = Python client library for Ceilometer
- pkgver = 2.9.0
- pkgrel = 3
- url = http://docs.openstack.org/developer/python-ceilometerclient/
+ pkgver = 2.9.1
+ pkgrel = 1
+ url = https://docs.openstack.org/python-ceilometerclient/latest/
arch = any
license = Apache
- checkdepends = python-pbr
- checkdepends = python2-pbr
- checkdepends = python-iso8601
- checkdepends = python-iso8601
- checkdepends = python-keystoneauth1
- checkdepends = python2-keystoneauth1
- checkdepends = python-oslo-i18n
- checkdepends = python2-oslo-i18n
- checkdepends = python-oslo-serialization
- checkdepends = python2-oslo-serialization
- checkdepends = python-oslo-utils
- checkdepends = python2-oslo-utils
- checkdepends = python-prettytable
- checkdepends = python2-prettytable
- checkdepends = python-requests
- checkdepends = python2-requests
- checkdepends = python-six
- checkdepends = python2-six
- checkdepends = python-stevedore
- checkdepends = python2-stevedore
checkdepends = python-mock
- checkdepends = python2-mock
checkdepends = python-subunit
- checkdepends = python2-subunit
checkdepends = python-tempest
checkdepends = python-testrepository
- checkdepends = python2-testrepository
- makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://github.com/openstack/python-ceilometerclient/archive/2.9.0.tar.gz
- sha512sums = 9955f683a07a2a5d7a65abe0a5100a2773f7938b69613a7ce24edcf7f42cd22d5e8a232ea5fe720715d8a344d16abf07c5288a9820f208c4815956cffd4f2702
-
-pkgname = python-ceilometerclient
depends = python-pbr
depends = python-iso8601
depends = python-keystoneauth1
@@ -48,16 +19,8 @@ pkgname = python-ceilometerclient
depends = python-requests
depends = python-six
depends = python-stevedore
+ source = https://github.com/openstack/python-ceilometerclient/archive/2.9.1.tar.gz
+ sha512sums = 76d379c51399233f5084ea7a75c2a2ebb1e178cf448601ef343b3b415c8ea42c90d3d287895b04b761b6e50e410a51be3ea8e3e65a5ef021f57ef7a27eafd55a
-pkgname = python2-ceilometerclient
- depends = python2-pbr
- depends = python2-iso8601
- depends = python2-keystoneauth1
- depends = python2-oslo-i18n
- depends = python2-oslo-serialization
- depends = python2-oslo-utils
- depends = python2-prettytable
- depends = python2-requests
- depends = python2-six
- depends = python2-stevedore
+pkgname = python-ceilometerclient
diff --git a/PKGBUILD b/PKGBUILD
index 840b0e8ea8c1..e0e3f7a60f60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,82 +1,35 @@
# Maintainer: Andy Botting <andy@andybotting.com>
-pkgname=('python-ceilometerclient'
- 'python2-ceilometerclient')
-pkgver='2.9.0'
-pkgrel='3'
+pkgname=python-ceilometerclient
+pkgver=2.9.1
+pkgrel=1
pkgdesc='Python client library for Ceilometer'
arch=('any')
-url="http://docs.openstack.org/developer/${pkgname}/"
+url="https://docs.openstack.org/$pkgname/latest/"
license=('Apache')
-makedepends=('python-setuptools'
- 'python2-setuptools')
-checkdepends=('python-pbr' 'python2-pbr'
- 'python-iso8601' 'python-iso8601'
- 'python-keystoneauth1' 'python2-keystoneauth1'
- 'python-oslo-i18n' 'python2-oslo-i18n'
- 'python-oslo-serialization' 'python2-oslo-serialization'
- 'python-oslo-utils' 'python2-oslo-utils'
- 'python-prettytable' 'python2-prettytable'
- 'python-requests' 'python2-requests'
- 'python-six' 'python2-six'
- 'python-stevedore' 'python2-stevedore'
- 'python-mock' 'python2-mock'
- 'python-subunit' 'python2-subunit'
- 'python-tempest'
- 'python-testrepository' 'python2-testrepository')
-source=("https://github.com/openstack/${pkgname}/archive/${pkgver}.tar.gz")
-sha512sums=('9955f683a07a2a5d7a65abe0a5100a2773f7938b69613a7ce24edcf7f42cd22d5e8a232ea5fe720715d8a344d16abf07c5288a9820f208c4815956cffd4f2702')
+depends=('python-pbr' 'python-iso8601' 'python-keystoneauth1'
+ 'python-oslo-i18n' 'python-oslo-serialization' 'python-oslo-utils'
+ 'python-prettytable' 'python-requests' 'python-six' 'python-stevedore')
+checkdepends=('python-mock' 'python-subunit' 'python-tempest'
+ 'python-testrepository')
+source=("https://github.com/openstack/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('76d379c51399233f5084ea7a75c2a2ebb1e178cf448601ef343b3b415c8ea42c90d3d287895b04b761b6e50e410a51be3ea8e3e65a5ef021f57ef7a27eafd55a')
-prepare() {
- cp -a "${srcdir}/${pkgname}-${pkgver}"{,-py2}
- export PBR_VERSION=$pkgver
-}
+export PBR_VERSION=$pkgver
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
python setup.py build
-
- cd "${srcdir}/${pkgname}-${pkgver}-py2"
- python2 setup.py build
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
python setup.py testr
-
- cd "${srcdir}/${pkgname}-${pkgver}-py2"
- PYTHON=python2 python2 setup.py testr
-}
-
-package_python-ceilometerclient() {
- depends=('python-pbr'
- 'python-iso8601'
- 'python-keystoneauth1'
- 'python-oslo-i18n'
- 'python-oslo-serialization'
- 'python-oslo-utils'
- 'python-prettytable'
- 'python-requests'
- 'python-six'
- 'python-stevedore')
- cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
}
-package_python2-ceilometerclient() {
- depends=('python2-pbr'
- 'python2-iso8601'
- 'python2-keystoneauth1'
- 'python2-oslo-i18n'
- 'python2-oslo-serialization'
- 'python2-oslo-utils'
- 'python2-prettytable'
- 'python2-requests'
- 'python2-six'
- 'python2-stevedore')
- cd "${srcdir}/python-ceilometerclient-${pkgver}-py2"
- python2 setup.py install --root="${pkgdir}" --optimize=1
- mv "${pkgdir}"/usr/bin/ceilometer{,2}
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
}
# vim:set ts=2 sw=2 et: