summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPavle Portic2021-03-29 11:44:26 +0200
committerPavle Portic2021-03-29 11:44:26 +0200
commit7bb320d798bd0c22332c1c5ff2eed5641e18d41f (patch)
tree6468612cdd4d2c318e221bd9f6521276698ca735
downloadaur-7bb320d798bd0c22332c1c5ff2eed5641e18d41f.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8280055774c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-certifi-system-store
+ pkgdesc = A certifi hack to use system trust store on Linux/FreeBSD
+ pkgver = 3021.3.16
+ pkgrel = 1
+ url = https://github.com/tiran/certifi-system-store
+ arch = any
+ license = MPL
+ makedepends = python-setuptools
+ depends = python
+ provides = python-certifi
+ conflicts = python-certifi
+ source = https://files.pythonhosted.org/packages/source/c/certifi-system-store/certifi-system-store-3021.3.16.tar.gz
+ sha256sums = 603be2b260ae2d5d025f584a219087683ff2ddcd09325ebb56b172cd07877057
+
+pkgname = python-certifi-system-store
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48274ba3f843
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Pavle Portic <archlinux@theedgeofrage.com>
+
+pkgbase='python-certifi-system-store'
+pkgname=('python-certifi-system-store')
+_module='certifi-system-store'
+pkgver='3021.3.16'
+pkgrel=1
+
+pkgdesc="A certifi hack to use system trust store on Linux/FreeBSD"
+url="https://github.com/tiran/certifi-system-store"
+license=('MPL')
+arch=('any')
+
+depends=('python')
+makedepends=('python-setuptools')
+provides=('python-certifi')
+conflicts=('python-certifi')
+
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('603be2b260ae2d5d025f584a219087683ff2ddcd09325ebb56b172cd07877057')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}